Bug 107174 - unable to unmount / eject CD or floppy, though these devices are NOT in use.
unable to unmount / eject CD or floppy, though these devices are NOT in use.
Status: CLOSED DUPLICATE of bug 106936
Product: Fedora
Classification: Fedora
Component: fam (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 107844 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 13:40 EDT by Elton Woo
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2003-10-15 13:40:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
In Fedora Core Test 3 (RH 9.0.95), I am unable to umount CD's
or floppies. Initally, I thought that this was the fault of
magicdev. However killing magicdev does not help. It was 
suggested on the list that the likely culprit is fam. 
This problem has been present in the previous
*two* betas, as well (9.0.93 and 9.0.94).

What is worse *now*, I am unable to unmount in KDE sessions,
either. The system insists that I must have root access to unmount
these devices. In 0.94, I was able to "bypass" the problem by
logging out of Gnome and into KDE to unmount / eject these devices.

NOTE: "floppy" is an LS-120 superdisk drive (/dev/hdb). The CD devices are DVD (/dev/hdc) alias /dev/cdrom, and CDRW (/dev/scd0 = /dev/hdd) alias /dev/cdrom1.

Version-Release number of selected component (if applicable):
fam-2.6.8-12

How reproducible:
Always

Steps to Reproduce:
1. Mount a floppy or CD disk.
2. Verify that the device is not being accessed (including minimized
window or console sessions)
3. Attempt to eject or unmount the device.
    

Actual Results:  System claims 'unable to unmount because the selected device is
busy'

Expected Results:  CD or floppy should unmount and eject (the ls-120 device *is* ejectable)

Additional info:

78324 seems to be related. I am able to unmount the CD in the DVD drive as root, but the CDRW drive is still 'busy'! This is after having logged out of Gnome, into KDE, and back into Gnome:

[root@dhcp-133-74 root]# umount /dev/cdrom
[root@dhcp-133-74 root]# umount /dev/cdrom1
umount: /mnt/cdrom1: device is busy
[root@dhcp-133-74 root]# umount /dev/scd0
umount: /dev/scd0: not mounted
[root@dhcp-133-74 root]# umount /dev/cdrom1
umount: /mnt/cdrom1: device is busy
[
Comment 1 Alexander Larsson 2003-10-17 03:49:33 EDT
Isn't this a duplicate of bug 78324?
Comment 2 Marius Andreiana 2003-10-20 14:40:16 EDT
duplicate of #106936
Comment 3 Alexander Larsson 2003-10-22 06:20:24 EDT

*** This bug has been marked as a duplicate of 106936 ***
Comment 4 Bill Nottingham 2003-10-23 21:57:59 EDT
*** Bug 107844 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Johnson 2004-02-16 00:58:21 EST
I have noticed that SCSI devices are the gremlins.  I have a CD and a
DVD Drive.   The CD Drive will unmount without problems.  However, my
DVD drive ( /dev/scd0 ) is recognized as a SCSI device.  My SCSI cdrom
will never let me Eject.  It claims the it is busy!
Comment 6 Red Hat Bugzilla 2006-02-21 13:59:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.