Bug 107190 - Soundcard used to test is wrong when two soundcards
Soundcard used to test is wrong when two soundcards
Status: CLOSED DUPLICATE of bug 81843
Product: Fedora
Classification: Fedora
Component: redhat-config-soundcard (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 14:43 EDT by Bjarke Skjernaa
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bjarke Skjernaa 2003-10-15 14:43:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
This should have been an addition to bug 81843, but it is not possible to add
comments (see bug 87920):

I have a similar problem on Severn (Fedora Test 3):

I have two soundcards

Via Technologies, VT82C686 AC97 Audio Controller (onboard)
Ensoniq, 5880 AudioPCI (SB PCI 128 as far as I remember)

When the Ensoniq card is chosen as the primary it always plays on that one no
matter whether I press the test button on the Via or Ensoniq page. Durring
install I got:

Pressing the testbutton on the Via page played through the Ensoniq no matter
what the primary card was set to.
Pressing the testbutton on the Ensoniq page played through the card chosen as
primary card.

When I try it right now by running redhat-config-soundcard, it always
plays through the Ensoniq. I dont know if it is related but it outputs:

[skjernaa@skjernaa skjernaa]$ redhat-config-soundcard
es1371: Device or resource busy
-8
es1371: Device or resource busy
-8
es1371: Device or resource busy
-8
es1371: Device or resource busy

On error per time I test and one when i quit redhat-config-soundcard


Version-Release number of selected component (if applicable):
redhat-config-soundcard-1.0.8-2

How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-soundcard
2. Choose any device as primary audio device (e.g. "VT82C686 AC97 Audio Controller")
3. Press "Play Test sound" at the tab of any of the soundcards
    

Actual Results:  The sound is played on the Ensoniq (SB PCI 128)

Expected Results:  The sound should have played on the soundcard which tab was
chosen.

Additional info:
Comment 1 Brent Fox 2003-10-15 17:56:01 EDT
There must be some process that is preventing the application from unloading the
es1371 module.  Is the sound volume applet currently in the panel?  
Comment 2 Bjarke Skjernaa 2003-10-17 03:25:30 EDT
Yes the volume applet was in the panel. Removing this removes the error message
(es1371: Device or resource busy) but not the problem (and not the -8 that is
also printed). Here is a complete test:

V: Via Technologies, VT82C686 AC97 Audio Controller (onboard)
E: Ensoniq, 5880 AudioPCI (SB PCI 128)

A line like

prim -> E  => E V V

describes that I changed the primary soundcard to Ensoniq, and tested three
times. The first time the sound came on the Ensoniq the second and third time on
the Via

When starting redhat-config-soundcard:

Primary: Ensoniq
Tab: Via
Test plays on E (also if I test more than once)
Tab  -> E  => E E E
Prim -> V  => E E E
Tab  -> V  => V V V
Prim -> E  => E E E
Prim -> V  => E V V
Tab  -> E  => E E E
Prim -> E  => V E E
Comment 3 David Balažic 2003-10-24 08:45:28 EDT
Same problem :

I havce :
 - onboard ALC650, VIA 8537
   via_82cxxx driver
 - sb64pci PCI card ( driver is es1370 )
   ensoniq ES1370 [AudioPCI]

in firstboot, the test sound is always played on the es1370.
If I change the primary to VIA, then it plays OK on the ES1370,
then try playing on VIA is also OK.

Hope you understand :-)
Comment 4 David Balažic 2003-11-10 04:41:22 EST
And the bug goes on...

Fedora Core 1
redhat-config-soundcard-1.0.8-2.noarch.rpm

oh, it is the same version as before.
Well , I'll post this, just that the bug does not get forgotten :-)
Comment 5 Brent Fox 2004-03-25 16:38:19 EST

*** This bug has been marked as a duplicate of 81843 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:59:11 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.