Bug 107233 - kernel panics shutting down
kernel panics shutting down
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 107390 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-15 20:29 EDT by Chris Ricker
Modified: 2015-01-04 17:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-18 10:50:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel oops screenshot (274.99 KB, image/png)
2003-10-15 20:34 EDT, Chris Ricker
no flags Details
Oops on 2.4.22-1.2093.nptl (1.12 KB, text/plain)
2003-10-17 04:54 EDT, Ralf Ertzinger
no flags Details
oops on shutdown with 2105 kernel (2.29 KB, text/plain)
2003-10-25 00:29 EDT, Tom Diehl
no flags Details

  None (edit)
Description Chris Ricker 2003-10-15 20:29:03 EDT
kernel-2.4.22-1.2093.nptl.athlon

When shutting down the system, the kernel panics

Modules loaded:

Module                  Size  Used by    Tainted: PF 
trident                32724   1 (autoclean)
ac97_codec             17064   0 (autoclean) [trident]
pcigame                 2952   0 (autoclean) [trident]
gameport                3380   0 (autoclean) [pcigame]
soundcore               6500   2 (autoclean) [trident]
cipcb                  34024   1 (autoclean)
powernow-k7             5473   0 (unused)
parport_pc             18788   0
parport                36800   0 [parport_pc]
orinoco_cs              5524   1
orinoco                39148   0 [orinoco_cs]
hermes                  7652   0 [orinoco_cs orinoco]
ds                      8616   1 [orinoco_cs]
yenta_socket           13728   1
pcmcia_core            56288   0 [orinoco_cs ds yenta_socket]
natsemi                19328   0
sg                     35852   0 (autoclean)
sr_mod                 17752   0 (autoclean)
ide-scsi               11984   0
scsi_mod              107080   3 [sg sr_mod ide-scsi]
ide-cd                 35488   0
cdrom                  33216   0 [sr_mod ide-cd]
keybdev                 2944   0 (unused)
mousedev                5428   1
hid                    24356   0 (unused)
input                   5824   0 [keybdev mousedev hid]
usb-ohci               21160   0 (unused)
usbcore                78368   1 [hid usb-ohci]
thermal                 8256   0 (unused)
processor              10776   0 [thermal]
fan                     2496   0 (unused)
button                  3692   0 (unused)
battery                 7072   0 (unused)
asus_acpi               9820   0 (unused)
ac                      2752   0 (unused)
ext3                   71524   3
jbd                    51732   3 [ext3]

System hardware:

00:00.0 Host bridge: ATI Technologies Inc AGP Bridge [IGP 320M] (rev 13)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 320M] (rev 01)
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 02)
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
00:08.0 Modem: ALi Corporation Intel 537 [M5457 AC-Link Modem]
00:0a.0 CardBus bridge: O2 Micro, Inc. OZ6912 Cardbus Controller
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Bridge: ALi Corporation M7101 PMU
00:12.0 Ethernet controller: National Semiconductor Corporation DP83815
(MacPhyter) Ethernet Controller
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 8
model name      : mobile AMD Athlon(tm) XP 2200+
stepping        : 1
cpu MHz         : 1788.886
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat
pse36 mmx fxsr sse syscall mp mmxext 3dnowext 3dnow
bogomips        : 3565.15


This panic is highly reproducible. It happens every time I shutdown, regardless
of how I shutdown (poweroff, halt, or reboot). It happens regardless of what
I've done on the system -- simply booting into runlevel 3, then halting will panic

Screenshot attached momentarily of kernel oops -- oops occurs after syslog
quits, unfortunately
Comment 1 Chris Ricker 2003-10-15 20:34:42 EDT
Created attachment 95213 [details]
kernel oops screenshot
Comment 2 Dave Jones 2003-10-16 10:36:22 EDT
Not interesting unless you can repeat it without the binary modules loaded.
Reopen if you can reproduce it with a clean system.
Comment 3 Chris Ricker 2003-10-16 10:45:28 EDT
Look at the screenshot. I get it w/ or w/o binaries loaded. That screenshot is
from a straight boot up, shutdown w/ no binaries ever loaded

The lsmod above is from a boot that at one point had vmware loaded, but I get it
even w/o ever loading vmware (only binary modules ever used on that box)
Comment 4 louisgtwo 2003-10-16 14:26:31 EDT
I get this oops also. I'm not running any binary modules. If someone can show me
how to take a screenshot I would.
Comment 5 Michael Young 2003-10-16 15:21:52 EDT
I have seen the same thing with vanilla 2093. Incidentally judging by the glare
the "screenshot" was taken with a digital camera.
Comment 6 Jim Cornette 2003-10-16 20:53:36 EDT
I had this problem on my desktop also during a screensaver. It recovered from it
ad scrolled down a lot of messages across the screen.

This behavior of scrolling garbage on the terminal was also present on kernel
initialzation. It appeared early on ad before the interactive portion of the bot
process.

This was on an 800 MHz PIII with an 815 chipset.
Comment 7 Tom Diehl 2003-10-16 23:03:43 EDT
Me three. For the record Mine says Not Tainted. Before I go to a lot of trouble
will attaching a serial termianl to it allow me to capture the exact oops? Would
that be useful info?? for me this is a 1.7 gig athlon with all of the updates
applied.
Comment 8 Chris Ricker 2003-10-16 23:14:18 EDT
Is anyone seeing the oops on shutdown on anything besides Athlons? Tom Diehl's
an Athlon, I'm a mobile Athlon....
Comment 9 louisgtwo 2003-10-16 23:53:28 EDT
Yes, I'm on a P4 box.
Comment 10 Ralf Ertzinger 2003-10-17 04:54:18 EDT
Created attachment 95263 [details]
Oops on 2.4.22-1.2093.nptl

I captured the oops via serial console, to make copy/paste easier. This is on a
1200MHz Duron.
Comment 11 Chris Ricker 2003-10-17 10:53:08 EDT
Still true on untainted kernel-2.4.22-1.2096.nptl.athlon
Comment 12 Dave Jones 2003-10-17 11:21:34 EDT
FWIW, I've found the patch that caused this.
It'll be fixed in the next push to rawhide.
Comment 13 Elton Woo 2003-10-17 13:46:09 EDT
kernel-2.4.22-1.2093.nptl still shows this oops on shutdown.
Comment 14 Don Vanco 2003-10-17 13:56:03 EDT
I am seeing the same oops on shutdown on the .2096 kernel for 686 - ping me if 
you need additional system details.

Don
Comment 15 Chris Ricker 2003-10-17 19:24:14 EDT
*** Bug 107390 has been marked as a duplicate of this bug. ***
Comment 16 Chris Ricker 2003-10-18 10:50:54 EDT
kernel-2.4.22-1.2097.nptl fixes, thanks
Comment 17 Tom Diehl 2003-10-25 00:29:29 EDT
Created attachment 95473 [details]
oops on shutdown with 2105 kernel

Note You need to log in before you can comment on or make changes to this bug.