Bug 107469 - /proc/cpuinfo incorrectly formatted on smp system
/proc/cpuinfo incorrectly formatted on smp system
Status: CLOSED DUPLICATE of bug 107762
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ingo Molnar
Brian Brock
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-18 15:06 EDT by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2003-10-18 15:06:04 EDT
Description of problem:

The "flags" line is improperly formatted on smp systems with "runqueue" inserted
between the work "flags" and the flags themselves.

Version-Release number of selected component (if applicable):
kernel 2.4.22-2097-nptl up & smp versions

**** cat /proc/cpuinfo on up system:

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 800.038
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat
pse36 mmx fxsr sse
bogomips        : 1595.80

------------------------------------------------------------------------------

***** on smp system:

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 10
cpu MHz         : 931.839
cache size      : 256 KB
physical id     : 0
siblings        : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           :
runqueue        : 0
 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx
fxsr sse
bogomips        : 1854.66
 
processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 10
cpu MHz         : 931.839
cache size      : 256 KB
physical id     : 0
siblings        : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           :
runqueue        : 1
 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx
fxsr sse
bogomips        : 1861.22
Comment 1 Gene Czarcinski 2003-10-22 12:13:01 EDT
Note:  I realize that Red Hat does not always pay a lot of attention to VMware
but these really screws things up for VMware users and I consider this a MUST FIX.

Personally, I have edited the vmware-config.pl to get around the problem but I
am not sure how may will be able to do that.
Comment 2 Bill Nottingham 2003-10-22 16:40:31 EDT

*** This bug has been marked as a duplicate of 107762 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.