Bug 107762 - Shared runqueue patch messes up /proc/cpuinfo output on SMP with Hyperthreading
Summary: Shared runqueue patch messes up /proc/cpuinfo output on SMP with Hyperthreading
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 107469 108119 (view as bug list)
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-22 19:34 UTC by Need Real Name
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-24 00:59:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to arch/i386/kernel/setup.c (872 bytes, text/plain)
2003-10-22 19:35 UTC, Need Real Name
no flags Details

Description Need Real Name 2003-10-22 19:34:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
The shared runqueue patch misformats /proc/cpuinfo output.  Specifically, the
flags line.  This causes VMware's configuration script to fail.  Attached is a
patch against arch/i386/kernel/setup.c to fix the issue.


Version-Release number of selected component (if applicable):
kernel-smp-2.4.22-1.2088.nptl

How reproducible:
Always

Steps to Reproduce:
cat /proc/cpuinfo on a SMP system with Hyperthreading

Actual Results:  The CPU flags are split across multiple lines.

Expected Results:  CPU flags should be on one line.

Additional info:

Comment 1 Need Real Name 2003-10-22 19:35:33 UTC
Created attachment 95398 [details]
Patch to arch/i386/kernel/setup.c

Comment 2 Bill Nottingham 2003-10-22 20:40:43 UTC
*** Bug 107469 has been marked as a duplicate of this bug. ***

Comment 3 Dave Jones 2003-10-24 00:59:22 UTC
Fixed.


Comment 4 Philipp Hügelmeyer 2003-10-28 17:56:57 UTC
*** Bug 108119 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.