Bug 1076443 - Remove python-setuptools-devel
Remove python-setuptools-devel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
ChangeAcceptedF21
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-14 07:09 EDT by Jaroslav Reznik
Modified: 2014-12-08 10:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 10:22:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pbokoc: fedora_requires_release_note-


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2014-03-14 07:09:17 EDT
This is a tracking bug for Change: Remove python-setuptools-devel
For more details, see: http://fedoraproject.org//wiki/Changes/Remove_Python-setuptools-devel

The python-setuptools package has carried a virtual Provide for python-setuptools-devel since 2009 for backwards compatibility.  We're going to remove this virtual Provide.  Packages which still BuildRequire python-setuptools-devel will need to be updated to Require: python-setuptools instead.
Comment 1 Toshio Ernie Kuratomi 2014-06-30 21:45:14 EDT
python-setuptools-devel virtual provides removed from the python-setuptools package.  python-setuptools-devel removed as a requires from all packages.  python-setuptools-devel removed as a BuildRequires from all packages except trac and python-repoze-what which FTBFS for an unrelated cause.  the necessary changes to the spec files of those two packages have been checked into git but the SRPM packages in the repository won't reflect that until they are successfully rebuilt.

This Change should be considered 100%.

python-repoze-what FTBFS bug: https://bugzilla.redhat.com/show_bug.cgi?id=1106805

trac FTBFS bug: https://bugzilla.redhat.com/show_bug.cgi?id=1107459
Comment 2 Jaroslav Reznik 2014-10-07 08:23:31 EDT
This message is a reminder that Fedora 21 Change Checkpoint: 100% Code Complete Deadline (Former Accepted Changes 100% Complete) is on 2014-10-14 [1].

All Accepted Changes has to be code complete and ready to be validated in the Beta release (optionally by Fedora QA). Required bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a point of contingency plan. All incompleted Changes will be reported to FESCo on 2014-10-15 meeting. In case of any questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/21/Schedule
Comment 3 Jaroslav Reznik 2014-10-13 06:59:41 EDT
Based on comment #1, moving to ON_QA as change is 100% code complete.

Note You need to log in before you can comment on or make changes to this bug.