Bug 654116 - dm_task_run failed, errno = 22, Invalid argument
Summary: dm_task_run failed, errno = 22, Invalid argument
Keywords:
Status: CLOSED DUPLICATE of bug 813954
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2
Version: 5.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jonathan Earl Brassow
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On: 813954 1077405
Blocks: 807971 1049888
TreeView+ depends on / blocked
 
Reported: 2010-11-16 22:08 UTC by Corey Marthaler
Modified: 2014-04-10 09:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-10 09:01:20 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Corey Marthaler 2010-11-16 22:08:12 UTC
Description of problem:
This may be related to bug 445253.

---------------------------------------------
TEST CASE=15
 base legs 1; convert to 2 legs;
 base log core; convert to disk log;
 active 1; sync=1; pvs=sufficient
---------------------------------------------
creating a base mirror on grant-03
  Error locking on node grant-01: device-mapper: create ioctl failed: Device or resource busy
  Failed to activate new LV.
couldn't create centi_base on grant-03


Nov 16 14:44:13 grant-03 qarshd[11584]: Running cmdline: lvcreate -n centi_base --mirrorlog core -m 1 -L 700M centipede
Nov 16 14:44:14 grant-03 lvm[10959]: Monitoring mirror device centipede-centi_base for events.
Nov 16 14:44:14 grant-03 lvm[10959]: dm_task_run failed, errno = 22, Invalid argument
Nov 16 14:44:14 grant-03 lvm[10959]: No longer monitoring mirror device centipede-centi_base for events.


Version-Release number of selected component (if applicable):
lvm2-2.02.74-3.el5    BUILT: Thu Nov 11 02:56:33 CST 2010
lvm2-cluster-2.02.74-3.el5    BUILT: Tue Nov  9 08:01:59 CST 2010
device-mapper-1.02.55-2.el5    BUILT: Tue Nov  9 06:41:00 CST 2010
device-mapper-event-1.02.55-2.el5    BUILT: Tue Nov  9 06:41:00 CST 2010
cmirror-1.1.39-10.el5    BUILT: Wed Sep  8 16:32:05 CDT 2010
kmod-cmirror-0.1.22-3.el5    BUILT: Tue Dec 22 13:39:47 CST 2009


How reproducible:
A few times

Comment 3 Jonathan Earl Brassow 2010-11-29 21:36:21 UTC
Can you tell me the test that was being run?  Or can we distill this down to a set of actions that causes the problem?

I don't think this is related to bug 445253.  Here, we fail from an invalid argument.  There we fail due to "in use" issues.

Comment 4 Corey Marthaler 2010-11-30 17:52:25 UTC
The test is 'centipede'.

./centipede -l $sts-lroot -R resourcefile.xml -r $sts-rroot

The specific testcase here was just a simple mirror create (implying a timing issue):

lvcreate -n centi_base --mirrorlog core -m 1 -L 700M centipede

Comment 6 Corey Marthaler 2011-04-29 19:46:56 UTC
I'm also seeing this at random times during single machine mirror failure testing.


taft-01 lvm: Monitoring mirror device helter_skelter-syncd_pri_leg_pri_log_3legs_2logs_1 for events.
taft-01 lvm: Another thread is handling an event. Waiting...
taft-01 lvm: Trying to up-convert to 2 images, 2 logs.
taft-01 lvm: Monitoring mirror device helter_skelter-syncd_pri_leg_pri_log_3legs_2logs_1_mlog for events.
taft-01 lvm: Another thread is handling an event. Waiting...
taft-01 lvm: Monitoring mirror device helter_skelter-syncd_pri_leg_pri_log_3legs_2logs_1_mlog for events.
taft-01 lvm: Another thread is handling an event. Waiting...
taft-01 lvm: Monitoring mirror device helter_skelter-syncd_pri_leg_pri_log_3legs_2logs_1 for events.
taft-01 lvm: Another thread is handling an event. Waiting...
taft-01 lvm: 2 missing and now unallocated Physical Volumes removed from VG.
taft-01 lvm: Repair of mirrored LV helter_skelter/syncd_pri_leg_pri_log_3legs_2logs_1 finished successfully.
taft-01 lvm: Primary mirror device 253:5 has failed (D).
taft-01 lvm: Device failure in helter_skelter-syncd_pri_leg_pri_log_3legs_2logs_1.
taft-01 lvm: syncd_pri_leg_pri_log_3legs_2logs_1 is consistent. Nothing to repair.
taft-01 lvm: Repair of mirrored LV helter_skelter/syncd_pri_leg_pri_log_3legs_2logs_1 finished successfully.
taft-01 lvm: helter_skelter-syncd_pri_leg_pri_log_3legs_2logs_1 is now in-sync.
taft-01 lvm: helter_skelter-syncd_pri_leg_pri_log_3legs_2logs_1_mlog is now in-sync.
taft-01 lvm: helter_skelter-syncd_pri_leg_pri_log_3legs_2logs_1 is now in-sync.
taft-01 qarshd: Running cmdline: dd if=/dev/zero of=/mnt/syncd_pri_leg_pri_log_3legs_2logs_1/ddfile count=10 bs=4M
taft-01 qarshd: Running cmdline: sync
taft-01 lvm: No longer monitoring mirror device helter_skelter-syncd_pri_leg_pri_log_3legs_2logs_1_mlog for events.
taft-01 lvm: dm_task_run failed, errno = 22, Invalid argument
taft-01 lvm: No longer monitoring mirror device helter_skelter-syncd_pri_leg_pri_log_3legs_2logs_1 for events.
taft-01 lvm: No longer monitoring mirror device helter_skelter-syncd_pri_leg_pri_log_3legs_2logs_1 for events.


Note You need to log in before you can comment on or make changes to this bug.