Bug 107838 - insufficient error from chkconfig-1.3.8-4
Summary: insufficient error from chkconfig-1.3.8-4
Status: CLOSED DUPLICATE of bug 74324
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: chkconfig (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-23 17:05 UTC by Jonathan Kamens
Modified: 2014-03-17 02:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2003-10-23 17:05:14 UTC
If you have a dangling link in /etc/init.d, chkconfig reports, "/etc/init.d: No 
such file or directory".  It should report the name of the specific file it 
couldn't read, not the directory name.

I try to resist editorializing, but I must say that this is not the first lame 
error-handling problem I've found in chkconfig.  To whoever wrote this package: 
Come on, guys, proper error-handling is not rocket science.  Get it right.

Comment 1 Bill Nottingham 2005-02-02 21:21:42 UTC
Fixed in 1.3.14-1.

*** This bug has been marked as a duplicate of 74324 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:59:23 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.