Bug 74324 - chkconfig stops if symlink cannot be resolved in /etc/init.d
chkconfig stops if symlink cannot be resolved in /etc/init.d
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: chkconfig (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Ben Levenson
:
: 103381 107838 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-20 09:57 EDT by Peter Bieringer
Modified: 2014-03-16 22:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.3.14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 15:57:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2002-09-20 09:57:46 EDT
Description of problem:
if /etc/init.d contains an unresolvable symlink to an external program,
chkconfig will stop immediately

Version-Release number of selected component (if applicable):
chkconfig version 1.3.5

How reproducible:
Always

Steps to Reproduce:
1. # ln -sf /tmp/notexist /etc/init.d/notexist
2. # chkconfig --list
keytable        0:off   1:on    2:on    3:on    4:on    5:on    6:off
...
syslog-ng       0:off   1:off   2:on    3:on    4:on    5:on    6:off
error reading from directory /etc/init.d: No such file or directory[root@gromit
init.d]#
	

Actual Results:  Not displaying anymore information

Expected Results:  Fulfilling list, perhaps displaying a message about such symlink

Additional info:
Comment 1 Bill Nottingham 2005-02-02 15:57:01 EST
fixed in 1.3.14-1.
Comment 2 Bill Nottingham 2005-02-02 16:02:22 EST
*** Bug 103381 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2005-02-02 16:21:49 EST
*** Bug 107838 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.