Bug 1082765 - Allow AGEING to be set in ifcfg-* scripts
Summary: Allow AGEING to be set in ifcfg-* scripts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.6
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Jan Ščotka
URL:
Whiteboard:
Depends On:
Blocks: 1083211 1083694
TreeView+ depends on / blocked
 
Reported: 2014-03-31 19:10 UTC by James W. Mills
Modified: 2018-12-05 17:57 UTC (History)
1 user (show)

Fixed In Version: initscripts-9.03.42-1.el6
Doc Type: Bug Fix
Doc Text:
Already covered in different bug.
Clone Of:
: 1083211 (view as bug list)
Environment:
Last Closed: 2014-10-14 06:28:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 772843 0 None None None Never
Red Hat Product Errata RHBA-2014:1448 0 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2014-10-14 01:05:44 UTC

Description James W. Mills 2014-03-31 19:10:56 UTC
Description of problem:

We need to allow ageing to be set in ifcfg-* scripts

Version-Release number of selected component (if applicable):

RHEL 6.x

How reproducible:

100%

Steps to Reproduce:

Add "AGEING=0" to an ifcfg-* file that is a bridge


Actual results:

No change in aging value when you run "brctl showstp <bridge>"

Expected results:

"brctl showstp <bridge>" shows "max age		  0.00"

Additional info:

A recent problem with internal blade switches not forwarding traffic led us to needing to disable ageing completely.  This method for manipulating the ageing of the bridge is much preferable to a standalone script executed after the interface is already up.

There is an upstream patch for this already:

https://git.fedorahosted.org/cgit/initscripts.git/commit/?id=81143a44c2f3b11a7a70a48d909e831c8cd3a79f

Comment 5 errata-xmlrpc 2014-10-14 06:28:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1448.html


Note You need to log in before you can comment on or make changes to this bug.