Bug 10855 - Installer formats twice
Installer formats twice
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Erik Troan
:
: 12106 12392 13658 13904 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-16 09:50 EDT by Chris Ricker
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 15:22:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2000-04-16 09:50:32 EDT
If you're using the GUI installer, and you select more packages than you
have room for, it first formats the drives before telling you that it's out
of room.  You then have the options of either selecting fewer packages or
adding partitions / making partitions bigger.  Even if you do the former,
and your partition table / formatting shouldn't need changing, RH 6.2 then
proceeds to format everything a second time.
Comment 1 Jay Turner 2000-04-17 10:45:59 EDT
The installer functionality was never meant to allow the user to go back and
change the package selection once the filesystems are formatted, so this is a
bug in the installer.  Future versions will make this restriction more apparent
to the user.
Comment 2 Michael Fulbright 2000-06-12 14:59:30 EDT
Test lab - please verify this bug is not present in latest internal version.
Comment 3 Brock Organ 2000-07-13 16:45:55 EDT
the current internal fix isn't resolved correctly ...

in TUI:

1) Displays a dialog "You don't have enough space, required: xxx Mb"
2) Press OK, install continues 
3) window "ready to install, the log file will be in /tmp" ...
4) Press OK to continue
5) Traceback

GUI:

1) Displays a dialog "You don't have enough space ..."
2) Press OK , install continues ...
3) window "ready to install, the log file will be in /tmp" ...
4) Press OK to continue
5) goto step 1 ; endless cycle
Comment 4 Glen Foster 2000-07-18 14:19:58 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 5 Erik Troan 2000-07-21 12:11:04 EDT
*** Bug 12007 has been marked as a duplicate of this bug. ***
Comment 6 Erik Troan 2000-07-21 12:16:23 EDT
*** Bug 12106 has been marked as a duplicate of this bug. ***
Comment 7 Brent Nordquist 2000-07-21 13:06:34 EDT
Just to make sure no data is lost:  the main concern of bug 12007 (now resolved
as a duplicate of this bug) is that when / is the partition that doesn't have
enough space, the warning dialog (both TUI and GUI installs) doesn't show "/",
it just has blanks (empty space).  Thus, the user doesn't know what partition is
too full.  Please make sure that's part of this fix.  Thanks!
Comment 8 Glen Foster 2000-07-21 14:04:03 EDT
This defect has been re-classified as MUST-FIX for Winston Gold-release
Comment 9 Erik Troan 2000-07-21 15:25:18 EDT
*** Bug 13658 has been marked as a duplicate of this bug. ***
Comment 10 Erik Troan 2000-07-21 16:00:55 EDT
*** Bug 13904 has been marked as a duplicate of this bug. ***
Comment 11 Michael Fulbright 2000-07-27 13:55:30 EDT
Would be hard to fix and does not cause any damage.
Comment 12 Chris Evans 2000-07-31 18:26:54 EDT
Are you guys mad?
You're not going to fix this?
Do you have any idea how frustrating it is to spend 10 mins selecting packages,
then be told "you need 5 more Mb free". Fine, so you use the fully enabled
"BACK" button to go back and deselect some poxy 10Mb package. Upon going forward
and re-starting the install it crashes after "preparing for install"
Are we talking about the same bug? There have been so many bugs logged in this
area that I'm afraid some serious ones, e.g. this one, have been marked as
duplicates.
Comment 13 Michael Fulbright 2000-07-31 19:12:08 EDT
We are late in the development cycle and after discussion of the installer team
this would take considerable time to address properly.  I  understand it is
frustrating to hit this bug and we will definately reevaluate how to handle it
in future releases.  There are unfortunately more critical bugs which can be
more easily fixed which are taking our development time.

We never said this wasn't a bug, btw.
Comment 14 Matt Wilson 2000-07-31 19:51:49 EDT
There are two bugs here.  One we will fix, one we won't.

The main problem you're seeing is that the loopback filesystem isn't unmounted
when going back from a failed attempt at a transaction.  This is the critical
bug, and it will be fixed.

The other bug is that it keeps formatting the drives every time you start an
install attempt.  This won't be fixed, sorry.
Comment 15 Michael Fulbright 2000-08-04 10:52:31 EDT
*** Bug 12392 has been marked as a duplicate of this bug. ***
Comment 16 Erik Troan 2000-08-08 15:22:00 EDT
This has been fixed internally (I think I got all of the cases, finally).

Note You need to log in before you can comment on or make changes to this bug.