Bug 12106 - installer hangs if not enough space available
installer hangs if not enough space available
Status: CLOSED DUPLICATE of bug 10855
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
: 12281 12292 12344 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-11 22:30 EDT by Red Hat Bugzilla
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-18 18:51:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-06-11 22:30:36 EDT
I only had 1 gig in /usr, and told it to install everything.  It popped up
a dialog box that I didn't have enough space, and then hung.
Comment 1 Red Hat Bugzilla 2000-06-26 00:06:31 EDT
The installer just does not deal with space problems as gracefully or accurately
as it should.

For beta 2 install, I made a 1700 M /usr partition.  I selected everything under
custom install (1496 M).  The installer told me I needed 150 M more free (which
shouldn't be true), and then hung.
Comment 2 Red Hat Bugzilla 2000-06-26 13:56:34 EDT
verified ... thanks for the report!
Comment 3 Red Hat Bugzilla 2000-06-26 17:48:29 EDT
Also see #12292. Similar (but sufficiently different not to close as a
duplicate)
Comment 4 Red Hat Bugzilla 2000-06-27 13:14:01 EDT
*** Bug 12292 has been marked as a duplicate of this bug. ***
Comment 5 Red Hat Bugzilla 2000-06-27 13:16:12 EDT
I marked 12292 as a duplicate of this even though the two bugs are slightly
different, when the installer handles insufficient space conditions better, both
issues should be resolved ...
Comment 6 Red Hat Bugzilla 2000-06-27 14:07:58 EDT
*** Bug 12281 has been marked as a duplicate of this bug. ***
Comment 7 Red Hat Bugzilla 2000-06-27 14:08:22 EDT
*** Bug 12344 has been marked as a duplicate of this bug. ***
Comment 8 Red Hat Bugzilla 2000-06-27 14:23:13 EDT
*** Bug 12392 has been marked as a duplicate of this bug. ***
Comment 9 Red Hat Bugzilla 2000-07-18 14:27:39 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 10 Red Hat Bugzilla 2000-07-18 18:32:17 EDT
Does this happen in beta3?
Comment 11 Red Hat Bugzilla 2000-07-18 18:51:49 EDT
Hi - yes BETA3 is still afflicted. I never finished installing BETA3 due to this
bug ;-)
NOTE!!!!!!
The bug gives the impression that the install hangs immediately after the "out
of space message". Maybe that happens for some people, but my experience has
always been this
1) "Out of space" message is shown.
2) I get an error box about being unable to unmount some partition. Usually
"/usr"
3) The installer happily lets me use "Back" to go back to package selection and
deselect a few packages
4) Upon going forward again from package selection, the hang occurs when the
installer checks for sufficient space the second time. As far as I remember the
"transferring install image" works OK, and the hang occurs immediately after the
"preparing to install" stage.
5) After the hang, the text console shows a python traceback which is
complaining about being unable to mount a partition because it is already
mounted.

Hope this helps!
Comment 12 Red Hat Bugzilla 2000-07-21 12:16:25 EDT

*** This bug has been marked as a duplicate of 10855 ***

Note You need to log in before you can comment on or make changes to this bug.