Bug 109256 - Radeon 9800 - System Freezes during startup of Gnome Splash Screen after logging in, Graphical Installer Startup, and FirstBoot
Radeon 9800 - System Freezes during startup of Gnome Splash Screen after logg...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
athlon Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 121604 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-06 00:52 EST by Shawn Walker
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-09 19:27:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Install Log Syslog (3.25 KB, text/plain)
2003-11-06 01:07 EST, Shawn Walker
no flags Details
Install Log (47.28 KB, text/plain)
2003-11-06 01:07 EST, Shawn Walker
no flags Details
XF86Config (3.06 KB, text/plain)
2003-11-06 01:08 EST, Shawn Walker
no flags Details
XFree86 Log (36.33 KB, text/plain)
2003-11-06 01:08 EST, Shawn Walker
no flags Details
Xsession Errors (292 bytes, text/plain)
2003-11-06 01:09 EST, Shawn Walker
no flags Details
E-mail to fedora-list (1.44 KB, text/plain)
2003-11-08 17:26 EST, Chris Heisel
no flags Details

  None (edit)
Description Shawn Walker 2003-11-06 00:52:24 EST
Description of problem:

System freezes shortly after XFree86 starts

Version-Release number of selected component (if applicable):


How reproducible:

Every Time

Steps to Reproduce:
1. Boot Fedora Core 1, use Graphical Installer, system access floppy
drive and then 'freeze'
2. or install using Text Mode installer, wait for system to reach the
'firstboot' program, screen comes up, draws firstboot completely, and
then system 'freeze'
3. or boot into single user mode, rpm -e rhgb, rpm -e firstboot, then
startup normally, when X comes up login into system, Fedora Gnome
splash screen comes up, and then "freeze"
  
Actual results:

System freezes after X starts up

Expected results:

System shouldn't "freeze" up (completely unresponsive, not even
numlock works)

Additional info:

My System:
ATi Radeon 9800 Pro AGP 128MB
Athlon XP 2100+
EPOX 8KHA+ (VIA KT266A AGP4X FastWrites Enabled)
512MB PC2100 DDR CAS 2.5
Logitech Dual Optical USB Mouse
M$ Internet Keyboard
3C0M SOHO 3c905x 10/100 Ethernet Card
SoundBlaster Audigy Gamer (EMU10K2)
Yamha LightSpeed CDRW 24x10x40
Sony Multiscan E400 (CPD-E400)

I will attach what logs I can find that I think are relevant
Comment 1 Shawn Walker 2003-11-06 01:07:28 EST
Created attachment 95751 [details]
Install Log Syslog
Comment 2 Shawn Walker 2003-11-06 01:07:50 EST
Created attachment 95752 [details]
Install Log
Comment 3 Shawn Walker 2003-11-06 01:08:13 EST
Created attachment 95753 [details]
XF86Config
Comment 4 Shawn Walker 2003-11-06 01:08:35 EST
Created attachment 95754 [details]
XFree86 Log
Comment 5 Shawn Walker 2003-11-06 01:09:04 EST
Created attachment 95755 [details]
Xsession Errors
Comment 6 Chris Heisel 2003-11-08 17:26:23 EST
Created attachment 95836 [details]
E-mail to fedora-list

I've experienced the same bug. The only similarities between our two systems
are: Radeon 9800, USB optical mouse (mine is M$), and an Audigy sound card
(mine is an Audigy 2).
Comment 7 David Rettig 2003-11-08 19:56:01 EST
Similar bug but no similar components...
I can get past the freeze by hard booting the system and ignoring the
FSCHK.
Comment 8 Chris Heisel 2003-11-08 21:23:33 EST
I hard booted and skipped the disk check, but the problem remained. I
tried doing the interactive boot and skipping firstboot.

The sequence went fine until and got me to the Fedora login screen --
since I had not created any users yet, I tried logging in as root,
which it accepted, but then froze on the screen after login.

It looked like a progress screen, but there was no progress indicated.
And again, the keyboard and mouse were non-responsive...
Comment 9 Ken Mumper 2003-11-09 19:47:46 EST
Same bug with identical components.  Radeon 9800, Audigy 2, MS 
Optical Wheel Mouse.
Comment 10 Ken Mumper 2003-11-09 20:03:16 EST
Same bug with identical components.  Radeon 9800, Audigy 2, MS 
Optical Wheel Mouse.
Comment 11 Kendal L. Montgomery 2003-11-11 15:08:22 EST
I've got the same problem happening.  Totally different hardware. 
Mine is a Dell Latitude CPi D300XT laptop (older). It's got 128M ram,
~6G hard drive.  The whole install process went fine, firstboot went
fine, but now almost everytime I start the system up it totally
freezes after about 2 minutes of being "up".  I normally can't even
get completely logged into gnome.  If I let it sit long enough it
hangs at the gdm login screen.  I've also had the freeze happen in
init 3 a few times, but if I start up in single user mode, and only
have a few service started it doesn't happen.  I'm starting to suspect
acpi or that microcode_ctl service.  I have not yet tried disabling
everything and adding one service at a time.
Comment 12 David Rettig 2003-11-13 21:05:10 EST
My problem disappeared after removing the rhgb option from
/boot/grub/grub.conf
Comment 13 Shawn Walker 2003-11-13 21:42:49 EST
Removing rhgb does nothing for me.

Using the ATi proprietary fglrx driver fixes this issue.
Comment 14 Tacitus 2003-11-15 12:23:16 EST
I think we're conflating different bugs.  rhgb doesn't matter for me.
 The original submitter is IMHO seeing a problem that happens with
9600 and 9800 Radeons and the "radeon" driver.  The key is, if you can
change your XF86Config to say "Driver vesa" and things work.

I installed RC1 from scratch.  My card (9600) was not autodetected,
and I left it as VESA.  The install went fine and things run fine. 
Later I changed it to use the included radeon driver.  On restarting,
the Gnome login screen comes up.  If I log in, the loading screen
comes up but it freezes hard before any of the icons are displayed. 
Ctrl-Alt-whatever does nothing.  Resetting, when get back to the Gnome
login screen I try the failsafe session.  Again I get a hard freeze.

My specs: Sapphire Radeon 9600 Pro UE, P4 2.4CGHz (HT on), Intel
875PBZ board, Audigy2, Seagate 7200.7 SATA, Samsung ATAPI DVD.
Comment 15 Craig O'Grady 2003-11-28 10:51:03 EST
same problem here, i think its to do with the radeon 9800 pro i have 
a hang at firewire detection and then floppy access in text mode and 
at first boot and eth0 detection in the gui loader. i'm going to try 
and install in text mode then update the radeon drivers in initlevel 
3, wish me luck lol. although i much prefer installing in graphical 
mode... this will have to do...
Comment 16 Gennady Feldman 2003-12-18 11:38:56 EST
Possible dupe of 108729?
Comment 17 Mike A. Harris 2003-12-18 12:58:24 EST
Yes, bug #108729 seems related.  I'll go through bugzilla at a future
date and find all dupes.  I just haven't had time to investigate this
issue yet, and the support for this hardware is experimental only,
so has not been high priority yet.  I'll probably look at it some
time after christmas.
Comment 18 Mark Pinto 2003-12-19 14:28:01 EST
same problem happens with my nvidia quadro 2
Comment 19 Syst3m Snip3r 2003-12-26 22:43:06 EST
So how do you fix the problem and change to go back to VESA generic 
card in the meantime if I cant login?
Comment 20 Shawn Walker 2003-12-27 10:16:35 EST
Either add 'single' to the kernel line temporarily by editing it at
boot time in grub, or hit the 'I' key during startup when it says hit
'I' for interactive startup and say 'no' to 'local' services or
'xfree'. Then edit the /etc/X11/XF86Config file and restart.
Comment 21 Matthew Lowrance 2004-01-07 09:27:08 EST
I just wanted to add that I have this problem as well.  I have an
NVIDIA card (Geforce2 FX) and not a Radeon, however I DO have
Microsoft Optical Scroll mouse.  I am running the stock NV driver, but
I will see if the NVIDIA drivers make any difference.
Comment 22 Alexander Larsson 2004-01-11 12:38:10 EST
I get this too on an Asus Radeon 9600 XT on an Asus A7V8X-X
motherboard (athlon 2600+).

It seems to be the issue described in:
http://www.mail-archive.com/xfree86@xfree86.org/msg11075.html

As said in that mail, adding the XaaNoScreenToScreenCopy option seems
to  fix this (but makes scrolling slow).
Comment 23 Alexander Larsson 2004-01-12 03:55:52 EST
Might be a kernel issue:
http://lkml.org/lkml/2003/12/7/32
Comment 24 adam gordon 2004-02-04 00:33:26 EST
Guys-

Check out ATI's website.  You can download the RPM from ATI's website.
 I installed it and it works great.  Check out the bug 114818 that I
submitted regarding this issue; the fix is also in there.

Of course you could always just use the Vesa driver, but then you
wouldn't get to build kernel modules and tell me, where's the fun in that?
Comment 25 Andrej Potokar 2004-02-15 15:17:41 EST
I have the same problem when trying to install Fedora. After the white
screen with mouse cursor appears, it's doing something with floppy
drive and the shortly after the floppy light shuts off (when it should
rung graphical interface) it freezes.
PC:
- nForce2 EPOX 8RDA+ motherboard with SoundStorm, onboard LANAC
- AthlonXP1700+ (Thouroughbred B) running at 11x194Mhz (2134Mhz)
- Radeon 9800 Pro
- 2x256MB PC 2700 RAM (Dual Channel)
- PS2 keyboard, PS2 Logitech Wheel mouse
- 20Gb IBM HDD, 120Gb 8Mb Seagate HDD
- CD-ROM, DVD-ROM
- ADSL
Comment 26 Paul Graydon 2004-03-08 09:06:57 EST
Same here.  Radeon 9800, system freezes on attempt to do anything in
graphical display.  Can get the other termnial screens to work so that
I can log in to command prompt.

- nForce2 Abit NF7-s, onboard LAN.
- Athlon (Barton) xp3000+ running at stock, for installing.
- Radeon 9800 Pro 128mb
- 2x256Mb PC3200 RAM, 1x512Mb PC3200 Ram (Dual Channel)
- MS Internet Pro USB keyboard, and Logitech USB optical mouse.  Have
run these as PS/2 to eliminate USB as cause, but to no avail.
- SB Live! Platinum, and also with Audigy 2 ZS.
- 120Gb HDD, and a 20Gb HDD.
- CD-Rom, DVD-Rom

Thats about it really..
Comment 27 Shawn M. Jones 2004-05-02 16:03:10 EDT
Possible dupe of bug 121604?
Comment 28 Shawn Walker 2004-05-02 16:39:10 EDT
Not a dupe, this bug was filed before that one.

Secondly, this is no longer a problem in Fedora Core 2 Test 3. So it's
been fixed.
Comment 29 Shawn M. Jones 2004-05-02 18:23:57 EDT
That teaches me to do 10 things at once.  Bug 121604 is a dupe of this
bug.  Sorry.
Comment 30 Shawn M. Jones 2004-07-16 23:57:59 EDT
*** Bug 121604 has been marked as a duplicate of this bug. ***
Comment 31 Mike A. Harris 2004-10-09 19:27:51 EDT
Radeon 9200/9600/9800, and the Pro, SE, and XT variants of these
are now officially supported in Fedora Core 2 and later OS releases.

Once you've upgraded to Fedora Core 2 or later, this hardware should
be automatically detected and configured.  If you experience problems
with the "radeon" driver in Fedora Core 2, please file a bug report
in the X.Org bugtracker located at http://bugs.freedesktop.org in
the "xorg" component.

Setting status to "CURRENTRELEASE"



Note You need to log in before you can comment on or make changes to this bug.