Bug 1088166 - [doc] DNF doesn't say you need root rights to run dnf update
[doc] DNF doesn't say you need root rights to run dnf update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-16 03:36 EDT by Jiri Eischmann
Modified: 2014-09-30 19:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.0.8-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-31 19:59:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Eischmann 2014-04-16 03:36:38 EDT
Description of problem:
DNF doesn't say you need root rights to run certain commands such as dnf update.
Istead of it, it proceeds and after downloading packages it gives you an error:
[Errno 13] Permission denied: '//var/lib/dnf' which doesn't really say much.

Version-Release number of selected component (if applicable):
0.4.20

How reproducible:
run 'dnf update' without root.


Expected results:
DNF should say right away that for this operation you need to have root rights.
Comment 1 Ales Kozumplik 2014-04-16 10:07:19 EDT
Thank you for your in-depth insight, Jiri.

This has already been reported, for instance bug 973510, bug 1038504, bug 1044995, bug 1053676 and of course the cult classic and mother of them all, bug 910133.

But I realize, with bugs like this trickling in time after time, it is probably time to have this firmly documented in our FAQ, which is what commit 37eefa7 provides.
Comment 2 Ales Kozumplik 2014-04-22 15:42:26 EDT
*** Bug 1090117 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2014-05-02 04:33:06 EDT
dnf-0.5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.1-1.fc20
Comment 4 Fedora Update System 2014-05-02 17:05:37 EDT
Package dnf-0.5.1-1.fc20, hawkey-0.4.14-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.5.1-1.fc20 hawkey-0.4.14-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5937/hawkey-0.4.14-1.fc20,dnf-0.5.1-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2014-05-28 08:10:57 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
Comment 6 Fedora Update System 2014-05-28 19:50:55 EDT
Package dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.0.8-2.fc20 libsolv-0.6.1-1.git6d968f1.fc20 hawkey-0.4.16-1.fc20 dnf-0.5.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6789/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2014-05-31 19:59:33 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.