Bug 109361 - Installer stops when anaconda tries to run.
Installer stops when anaconda tries to run.
Status: CLOSED DUPLICATE of bug 109462
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-11-06 21:12 EST by Adam Julius
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:59:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Julius 2003-11-06 21:12:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
I put in the boot CD to reinstall and got an error while trying to 
load Anaconda.  I also got another error at that point when I tried 
to install Fedora for the 1st time, but I can not duplicate that 
error again to give the error message.  The bug I did get the error 
message for was the following:

/usr/bin/python2.2:relocation error /lib/libm.so.6: symbol 
__cxa_finalize, version GLIBC_2.1.3 not defined in file libc.so.6 
with link time reference
install exited abnormally

Version-Release number of selected component (if applicable):

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. Boot from Fedora Core 1 Disk 1 using graphical install mode


Additional info:
Comment 1 Jeremy Katz 2003-11-06 21:17:11 EST
Can you verify your media following the instructions available from
Comment 2 Adam Julius 2003-11-06 21:27:35 EST
Media is fine.  I had it verified already.  I got the error after I 
attempted another install. 

I have Fedora working fine now using the same disks as well.  It 
seems like 1 out of every many times, the anaconda installer will 
not work.  On the 1st time I installed, it failed while trying to 
run the anaconda installer but I cant recall the error message.  The 
2nd install it worked fine.  I tried to duplicate the original 
error, but instead wound up with the error I mentioned above.  It 
must have been on the 6th attempted install bootup that it failed.  

Comment 3 Jeremy Katz 2003-11-06 21:36:41 EST
That sounds a lot like questionable media.  Unfortunately, mediacheck
isn't 100% for finding problematic media.  CD media is getting to be
about like floppies in quality :(
Comment 4 Adam Julius 2003-11-06 22:11:12 EST
I will reburn on a CDRW that I have thats a different media.  I have a
Dell Dimension 8300 with a DVD + CDRW drive.  I had the media
verified, and checked and its fine.  Im quite sure its not the media
thats the problem.  But I will try it again on another media to double
Comment 5 Adam Julius 2003-11-06 22:51:26 EST
Reburned to a CDRW of different media.  Installed and it again 
install exited abnormally during when it tries to run anaconda.  If 
it was due to bad media, I wouldnt have the problem in the exact 
same spot on 2 different cd's.  And the install wouldnt also work 
fine when attempted to run again if the ISO image file I burnt was 
bad.   Both CD's verify fine.  
Comment 6 Need Real Name 2003-11-07 15:56:03 EST
See bug 109438
Comment 7 Adam Julius 2003-11-08 13:02:48 EST
Burn was conducted with Nero 5.5 using disc at once mode on Windows 
XP with a Memorex 48x12x48 CDRW Drive (OEM is liteon) with Memorex 
firmware.  Machine is a Dell Dimension 8300.  I burn lots of discs 
and they all burn fine.  
Comment 8 Jeremy Katz 2003-11-08 15:43:07 EST
Does booting with 'linux allowcddma' help at all?
Comment 9 Adam Julius 2003-11-08 16:24:35 EST
How do I boot with linux allowccddma?  

The problem with the errors at the start of when running anaconda 
dont happen all the time as I said before.  It only happens one out 
of every so many times.  Just rerunning seems to do the trick.  
Booting from the CD works fine and the linux kernel itself works 
fine.  Its just as the anaconda installer tries to run, sometimes it 
will stop during that period with an error such as the one I 

Do I enter that when I put in the CD Im thinking?  If thats it I 
will try that now and then keep rebooting (i have a working linux 
system now) to see if the error comes up again.  

Comment 10 Adam Julius 2003-11-08 16:39:20 EST
I tried the linux cddma option when I put in the cd.  It goes till 
it tries to run anaconda and then I get install exited abnormally 
and the shutdown procedure.  

The boot drive is a Samsung 16X DVD drive if that makes any 
difference.  Boot drive is different than my CDRW drive which is the 
secondary drive.  

Comment 11 Jeremy Katz 2003-11-10 16:08:24 EST
Did you use cddma or allowcddma?  Instead of just hitting enter at the
syslinux prompt, you would type 'linux allowcddma' (no quotes) at
which point, DMA won't be forcibly disabled for your drive and should
fix things.
Comment 12 Adam Julius 2003-11-10 17:26:15 EST
Ill try it again later tonight with linux allowcddma and will see how 
it goes.  

Comment 13 Adam Julius 2003-11-10 20:03:18 EST
Ok I booted up multiple times and each time it loaded anaconda 
successfully with the linux allowcddma 

Now my question is:  Can this be autodetected in the OS, or can it be 
determined when the allowcddma function is necessary (for certain 
drives or whatnot) so that the user can be told to add this before 
booting, or is this an actual bug that needs to be resolved?  

Comment 14 Dave Jones 2003-11-17 15:14:03 EST

*** This bug has been marked as a duplicate of 109462 ***
Comment 15 Red Hat Bugzilla 2006-02-21 13:59:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.