Bug 109560 - utf-8 problem with umlauts persists
utf-8 problem with umlauts persists
Status: CLOSED DUPLICATE of bug 108720
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 13:07 EST by Christian Paratschek
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 14:45:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Paratschek 2003-11-09 13:07:04 EST
Description of problem:

this is a bug that has been reported already 1 year ago. see bug
75982. i wanted to open a new bug here because this is really a major
annoyance for german users of fedora/redhat (and i guess it might as
well be the case for french/spanish/whatever users too, as i don't
believe that this problem is solely related to german umlauts...

fedora does not display german umlauts correctly. the solution to this
problem is editing /etc/sysconfig/i18n to user LANG="de_DE@euro"
instaed of LANG="de_DE.UTF-8"

i did so for rh8 and rh9 and i still do it now but, as i see it, this
should be solved somehow. 

related to this problem is a general lack of i18n: 
- german spellchecking is not installed for openoffice
- mounting windows-shares via the "network server" button in the
start-menu brings the same problem. 

this should not be the case. where's the sense in including a nice
"one click to your windows-networked shares"-button if i still have to
do it by hand? (because all files with umlauts are not displayed
correctly)

Version-Release number of selected component (if applicable):

How reproducible:

install fedora core in german and do either:
- mount a fat32 share on the local computer (with files with umlauts
on it)
- create a new document in openoffice and try to do the spellchecking
for german
- mount a share on a windows-machine in your lan via the "network
servers" button

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Need Real Name 2003-12-03 16:45:30 EST
There is also this tiny little problem that the keyboard doesn't work
in OpenOffice except for ascii characters. This means that you simply
can't type anything but English in OpenOffice, even though it has been
localized to other languages (I'm using Danish and can't type).

A small fix is to modify the file
/usr/share/applications/redhat-word-processor.desktop, so that it sets
LANG=da_DK.iso-8859-1 before launching OpenOffice, but:

- Clicking on a file in Nautilus will still not work well
- The File/Open and File/Save will then operate in iso-8859-1 instead
of utf-8, and generate invalid filenames...
Comment 2 Dan Williams 2003-12-04 10:47:38 EST
No de_DE spellchecking is more of a dictionary/thesaurus problem.

*** This bug has been marked as a duplicate of 108720 ***
Comment 3 Caolan McNamara 2004-11-01 14:45:12 EST
close as duplicate

Note You need to log in before you can comment on or make changes to this bug.