Bug 109607 - DNS doesn't work with xDSL unless addresses are manually entered
DNS doesn't work with xDSL unless addresses are manually entered
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 00:34 EST by Andre Robatino
Modified: 2014-03-16 22:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 21:41:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2003-11-10 00:34:32 EST
Description of problem:
  After creating an xDSL connection with a fresh install of FC1, upon
connecting there is no name service.  The cause is that the DNS
addresses are automatically acquired and entered into
/etc/ppp/resolv.conf, but not into /etc/resolv.conf.  I worked around
this by manually entering the 2 DNS addresses under the DNS tab in
redhat-config-network.  I'm not sure whether initscripts is the right
component for this bug.

Version-Release number of selected component (if applicable):
initscripts-7.42-1

How reproducible:
always

Steps to Reproduce:
1.  Configure an xDSL interface.  Do _not_ enter the DNS addresses
manually, but let them be acquired automatically.
2.  Bring up the interface.
  
Actual results:
  No name service.  Must copy the DNS addresses which appear in
/etc/ppp/resolv.conf into redhat-config-network for them to be recognized.

Expected results:
  Should have name service without manually entering the DNS addresses.

Additional info:
  I reported this in bug #105748.
Comment 1 David Balažic 2004-01-10 15:00:53 EST
Same bug here.

 - installed FC1
 - using redhat-config-network I set up and ADSL connection
 - works, except /etc/resolv.conf is not populated, have to do it
manually. /etc/pp/resolv.conf gets the correct data

Seems there are a lot of duplicates of this bug : 105748, 109578, 98786
Comment 2 David Balažic 2004-01-10 15:29:34 EST
Renaming ( changing it's nick ) the xDSL connection to ppp0 supposedly
fixes the problem. I personally did not try it.
Comment 3 Jef Spaleta 2004-02-02 12:15:20 EST

*** This bug has been marked as a duplicate of 109601 ***
Comment 4 David Balažic 2004-02-08 09:10:04 EST
This is not a duplicate of bug 109601. It is not fixed by
initscripts-7.42.2-1

Here is what I did :
 - install FC1 fresh ( Personal Desktop minus Print Support and Office
Apps )
 - update everything to latest as of 7-feb-2004 ( including
initscripts-7.42.2-1 )
 - reboot
 - Start Menu -> System Settings -> Network -> New -> xDSL Connection
, enter Provider name, Login name and  Password, click Apply
 - reboot
 - log in as non-root into X
 - Start Menu -> System Tools -> Network Device Control -> Activate
hte xDSL connections

Results : everything works, except DNS as /etc/resolv.conf is empty.
After adding the line "nameserver 193.189.160.11" ( got server address
from /var/log/messages :
Feb  8 14:53:32 localhost pppd[6649]: primary   DNS address 193.189.160.11
Feb  8 14:53:32 localhost pppd[6649]: secondary DNS address 193.189.160.12
, everything works OK.
Comment 5 Bill Nottingham 2004-03-16 21:58:46 EST
Is PEERDNS set in your ifcfg file?
Comment 6 David Balažic 2004-03-17 03:22:22 EST
Can't check right now. I have everything as installed by fresh fedora
core test1 system. I haven't changed anything, just set up an xDSL
connection by that GUI tool. Then I also tried updating every packages
to latest versions as of 7-feb-2004 ( see above ).
Comment 7 Andre Robatino 2004-03-17 09:49:27 EST
  PEERDNS=yes in mine.
Comment 8 Bill Nottingham 2005-04-28 21:41:55 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response. Please reopen if this persists on current releases such as Fedora Core 3.

Note You need to log in before you can comment on or make changes to this bug.