Bug 109624 - Workspace switcher acts oddly both in metacity and sawfish
Workspace switcher acts oddly both in metacity and sawfish
Status: CLOSED DUPLICATE of bug 120652
Product: Fedora
Classification: Fedora
Component: libwnck (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 08:50 EST by Jan "Yenya" Kasprzak
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2003-11-10 08:50:10 EST
Description of problem:
When using sawfish window manager, clicking with left mouse button
into the workspace switcher does not switch to the clicked workspace,
but it also moves the windows in this workspace to the completely
new position, sometimes partly out of the screen.

When using metacity, the workspace switcher works as expected,
but only windows on the current workspace are visible in the applet.

Version-Release number of selected component (if applicable):
gnome-panel-2.4.0-3
metacity-2.6.3-1
sawfish-1.3-2
Comment 1 Lance A. Brown 2003-11-12 02:38:38 EST
I can confirm this behaviour under sawfish.  It makes it very
difficult to use the workspace switcher.
Comment 2 Jan "Yenya" Kasprzak 2003-11-12 05:52:57 EST
I've discovered, that if you click to the upper left corner of the
workspace in the workspace switcher, windows are on the same position
(depending on how exactly do you manage to click to the corner). If
you click somewhere else, windows are moved up and left depending on
how far
from the corner did you clicked.

OTOH, after restarting my session, the workspace switcher works
correctly under metacity (it was probably something with starting
metacity after sawfish has been killed). So only the first part of the
bug remains, and it _may_ be related to sawfish rather than the
workspace switcher.
Comment 3 Tim Becker 2003-11-15 13:12:41 EST
I have the same issue and found this gnome bug id

http://bugzilla.gnome.org/show_bug.cgi?id=122086

which has a patch for pager.c in libwnk.

Applying this patch fixed this issue for me.
Comment 4 Lance A. Brown 2003-11-15 23:35:47 EST
Greetings,

I pulled down the patch and added it to the libwnck RPM for Fedora
Core 1.  You can find the modified RPMs at:

http://www.bearcircle.net/RPMS/
Comment 5 Jan "Yenya" Kasprzak 2003-11-19 12:24:07 EST
The above URL does not have the source RPM, so I have decided to build
my own RPMs -- you can grab the source RPM and i386 binary RPMs at
ftp://ftp.linux.cz/pub/linux/people/jan_kasprzak/libwnck
(be sure to check the GPG signature against GPG key ID 1024R/D3498839).

Component changed from sawfish to libwnck. Fedora people, please
incorporate this to the next release and close the bug.

The patched RPMs fix also the bug #109623.
Comment 6 Mark McLoughlin 2004-07-27 04:26:10 EDT

*** This bug has been marked as a duplicate of 120652 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:59:55 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.