Bug 109722 - mozilla crashes on this URL [zero length fonts cache files]
Summary: mozilla crashes on this URL [zero length fonts cache files]
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL: http://www.chipdocs.com/pndecoder/dat...
Whiteboard:
Keywords:
: 112442 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-11 13:36 UTC by chip piller
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 15:41:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description chip piller 2003-11-11 13:36:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Mozilla crashes when I try to access this URL:
http://www.chipdocs.com/pndecoder/datasheets/SMNS/SFH217.html

Version-Release number of selected component (if applicable):
mozilla-1.4.1-17

How reproducible:
Always

Steps to Reproduce:
1.start mozilla
2.try to access the aforementioned website URL 
3.mozilla crashes
    

Actual Results:  mozilla crashes

Expected Results:  mozilla should be more robust, it should not die
when going to certain websites

Additional info:

Comment 1 Wendigo 2003-11-13 19:33:10 UTC
The same happens if I try to access http://www.gnu.org
always.

Comment 2 Wendigo 2003-11-14 00:01:45 UTC
It also crashes on http://www.debian.org

This is too much. It seems like a Microsoft release of Mozilla.

Comment 3 Wendigo 2003-11-14 01:37:41 UTC
This problem is arises after upgrading from RH9 to Fedora. It seems
the problem is Mozilla trying to use a font that no longer exists.
See bug 109334 for a workaround.

I created a simlink to the new font and now it works..


Comment 4 Need Real Name 2003-11-14 04:21:11 UTC
None of these pages cause any problems on either of the Fedora
machines (both of which were RedHat 9 machines and were upgraded) that
I use. Could you have a corrupt font installed?

Comment 5 Wendigo 2003-11-14 14:39:39 UTC
The font that Mozilla was trying to use didn't existed. 
The symlink to the new font solved the problem with the webpages I was
trying to watch but. The address of the original bug. Still crashes
Mozilla. I guess it's another font.

http://www.chipdocs.com/pndecoder/datasheets/SMNS/SFH217.html

Seems the upgrade forgot to do something...



Comment 6 chip piller 2003-11-20 14:44:29 UTC
I updated mozilla to version 1.4.1-18 and this version of mozilla
still crashes on this URL.

Comment 7 Christopher Blizzard 2003-12-02 22:29:39 UTC
This does work in my 1.6b trunk build, but crashes my 1.4.1 build.  So
it's been fixed upstream at some point.

Comment 8 chip piller 2003-12-12 03:04:44 UTC
My wife came across another URL that crashes mozilla:
http://www.cartoonnetwork.com/play/adventure/knd_escapemission/index.html

The upstream fix mentioned in comment #7, will Fedora Core see this
fix in an updated mozilla anytime soon?  

What exactly is on these web sites that causes mozilla to crash? 

Comment 9 Harald Korneliussen 2003-12-19 18:57:06 UTC
*** Bug 112442 has been marked as a duplicate of this bug. ***

Comment 10 Harald Korneliussen 2003-12-19 19:24:46 UTC
Ah! Now that I created symlinks to the appropriate japanese fonts
things work on the gnu site, the debian site, and the google errors I
reported in bug 112442. And the cartoon network site never seemed to
cause a problem. However

http://www.chipdocs.com/pndecoder/datasheets/SMNS/SFH217.html

still crashes mozilla, and my strace dump doesn't even contain the
word "font". Looks like this is another bug.

Comment 11 Warren Togami 2004-01-29 02:04:13 UTC
Everyone who has these mozilla crashes, please test mozilla-1.6-0 from
rawhide on your FC1 systems and report back if that fixes the problem
or not.

Comment 12 Harald Korneliussen 2004-01-29 11:48:38 UTC
I can only find the source RPM, but I'll give it a try.

Comment 13 Wendigo 2004-01-29 15:09:22 UTC
Ok. I installed Mozilla 1.6 from rawhide. Now it doesn't crash on any
of the pages. Much faster too. The only problem I had to install with

rpm -Uvh --nodeps *.rpm 

because it complained of Epiphany needing it. 

Now Epiphany doesn't work...

Should I download Epiphany from Rawhide too?...

Comment 14 Jef Spaleta 2004-01-29 15:41:42 UTC
Closing this as rawhide, since we've had confirmation in comment 13




Note You need to log in before you can comment on or make changes to this bug.