Bug 1100530 - These APIs also need to add to `guestfish -h` command list
Summary: These APIs also need to add to `guestfish -h` command list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs
Version: 6.5
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1103877
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-23 03:16 UTC by Lingfei Kong
Modified: 2015-07-22 05:55 UTC (History)
6 users (show)

Fixed In Version: libguestfs-1.20.11-12.el6
Doc Type: Bug Fix
Doc Text:
The output of the "guestfish -h" command did not include command aliases, which have now been added.
Clone Of:
Environment:
Last Closed: 2015-07-22 05:55:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1444 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2015-07-20 18:44:02 UTC

Description Lingfei Kong 2014-05-23 03:16:41 UTC
Description of problem:
I can get 541 APIs by pressing <TAB> in guestfish interactive model, but only 503 APIs can find in `guestfish -h` command list.

The lost 38 APIs:
 add
 add-drive-opts
 add-ro
 allocate
 append
 attach-method
 autosync
 cachedir
 direct
 domain
 emacs
 exit
 grep-opts
 less
 manual
 memsize
 mkfs-opts
 mkswap-opts
 network
 ntfsresize-opts
 path
 pgroup
 pid
 q
 qemu
 recovery-proc
 run
 selinux
 smp
 tar-in-opts
 tar-out-opts
 tmpdir
 trace
 umount-opts
 unmount
 unmount-all
 verbose
 vi

Version-Release number of selected component (if applicable):
libguestfs-1.20.11-3.el6

How reproducible:
100%

Steps to Reproduce:
1. Get all APIs by run command `guestfish -h`
2. Enter into guestfish interactive model
3. Get all the APIs by pressing <TAB> in guestfish command
4. diff the APIs you get at step 1 and step 3


Actual results:
38 APIs appear in step 3 command list and not appear in step 1 command list


Expected results:
The command list of step 1 and step 3 are the same

Additional info:

Comment 2 Richard W.M. Jones 2014-05-23 08:49:55 UTC
See: https://bugzilla.redhat.com/show_bug.cgi?id=1100528#c2

Comment 5 Hu Zhang 2014-12-10 09:49:56 UTC
Could reproduce the bug.

Packages Version:
libguestfs-1.20.11-12.el6.x86_64

Reproduce steps:
1. Get all APIs by run command `guestfish -h`
   It returns 531 APIs.
2. Enter into guestfish interactive model
3. Get all the APIs by pressing <TAB> in guestfish command
   It returns 541 possible APIs.
So there is still a quantitative difference.

Not fixed.

Comment 6 Pino Toscano 2014-12-16 12:13:00 UTC
(In reply to Hu Zhang from comment #5)
> Could reproduce the bug.
> 
> Packages Version:
> libguestfs-1.20.11-12.el6.x86_64
> 
> Reproduce steps:
> 1. Get all APIs by run command `guestfish -h`
>    It returns 531 APIs.
> 2. Enter into guestfish interactive model
> 3. Get all the APIs by pressing <TAB> in guestfish command
>    It returns 541 possible APIs.
> So there is still a quantitative difference.

Most of the difference is due to the -opts commands, which are not meant to be documented. See also bug 1100528, comment 2.

The other two commands not listed in -h are "exit" and "q", both aliases for "quit", which makes sense only in interactive mode (guestfish in non-interactive mode already quits on its own after the last command).

Moving back to ON_QA.

Comment 7 Hu Zhang 2015-03-10 07:07:34 UTC
Verified with the package Version:
libguestfs-1.20.11-12.el6.x86_64

Reproduce steps:
1. Get all APIs by run command `guestfish -h`
   It returns 531 APIs.
2. Enter into guestfish interactive model
3. Get all the APIs by pressing <TAB> in guestfish command
   It returns 541 possible APIs.

According to the Comment #6, fixed.

Comment 10 errata-xmlrpc 2015-07-22 05:55:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1444.html


Note You need to log in before you can comment on or make changes to this bug.