Bug 1101297 - [RFE] Allow fully automatic deployment process for hosted-engine
Summary: [RFE] Allow fully automatic deployment process for hosted-engine
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.4.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Simone Tiraboschi
QA Contact: Artyom
URL:
Whiteboard:
: 1186742 (view as bug list)
Depends On:
Blocks: 1217106
TreeView+ depends on / blocked
 
Reported: 2014-05-26 16:35 UTC by Artyom
Modified: 2016-03-09 18:51 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.6.0-alpha1
Doc Type: Enhancement
Doc Text:
With this release, Self-Hosted Engine setup can be fully automated by using the RHEV-M Virtual Appliance and dynamically configuring it with cloud-init.
Clone Of:
Environment:
Last Closed: 2016-03-09 18:51:07 UTC
oVirt Team: Integration
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0375 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2016-03-09 23:48:34 UTC

Description Artyom 2014-05-26 16:35:50 UTC
Description of problem:
Now hosted-engine --deploy process wait input from user, on steps, like OS installation and engine installation. It very useful to make it fully automatically also for testing and also for user it will useful just give answer-file and not wait for each step.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.1.2-5.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Run hosted-engine --deploy
2.
3.

Actual results:
Deployment process waiting for user input on stages like OS and engine installation.

Expected results:
Fully automatic deployment with answer file 

Additional info:
Sandro proposed, something like this:
I guess we can just pass 1 to OS setup dialog with an additional env variable:
it will wait for VM shutdown before continuing.
For the next one we can just add a 5 seconds sleep and pass 1 using the same additional env variable:
it will cause an output saying engine is not live and try again after checking its config.(for this option we also need to add some flag to answer file like automatic_deployment, also timeout and sample time values)

Comment 1 Itamar Heim 2014-06-02 10:36:50 UTC
is this just for unattended setup for testing?
(because for production deployments, the plan is to make this simpler via the hosted-engine guest image as described in https://bugzilla.redhat.com/show_bug.cgi?id=1103409#c2)

Comment 2 Yedidyah Bar David 2014-06-02 11:31:28 UTC
It's about the interaction on the host, unrelated to the engine VM stuff. Currently this interaction can't be fully automatic. In principle it can be - we'll need to make the verification questions (OS is setup? engine is setup?) loop until success (probably with some timeout) (as well as making them answerable from the answer file).

Comment 3 Sandro Bonazzola 2015-02-03 13:29:45 UTC
*** Bug 1186742 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2016-03-09 18:51:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0375.html


Note You need to log in before you can comment on or make changes to this bug.