Bug 1103869 - RBAC UI - clicking a role in the UI should go to filters page
Summary: RBAC UI - clicking a role in the UI should go to filters page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Daniel Lobato Garcia
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1192852 (view as bug list)
Depends On:
Blocks: 1171330
TreeView+ depends on / blocked
 
Reported: 2014-06-02 18:56 UTC by Tom McKay
Modified: 2019-04-01 20:26 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:41:04 UTC


Attachments (Terms of Use)
on clicking a role, UI opens page to edit the role name along with filters tab. (75.50 KB, image/png)
2015-10-20 08:58 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC
Foreman Issue Tracker 4369 None None None 2016-04-22 15:12:30 UTC

Description Tom McKay 2014-06-02 18:56:40 UTC
It is very frustrating to click a role in the list and be taken to a page to edit the name. From my usage so far, this is not a common use case. Predominantly I am interested in seeing the filters.

Comment 1 Tom McKay 2014-06-02 18:56:43 UTC
Created from redmine issue http://projects.theforeman.org/issues/4369

Comment 2 Tom McKay 2014-06-02 18:56:47 UTC
Upstream bug assigned to dlobatog@redhat.com

Comment 4 Daniel Lobato Garcia 2014-06-02 22:37:54 UTC
This is being tracked here: https://github.com/theforeman/foreman/pull/1342

I'll probably change it to put the filters list in the tab.

Comment 5 Bryan Kearney 2014-10-07 12:02:01 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/4369 has been closed
-------------
Daniel Lobato Garcia
https://github.com/theforeman/foreman/pull/1342
-------------
Daniel Lobato Garcia
Applied in changeset commit:4ac62a6a87799c384a7333924e75fe918d389a46.

Comment 6 sthirugn@redhat.com 2014-10-10 20:12:54 UTC
Failed. Clicking on the role name takes me to a page to edit the name.

Version Tested:
Nightly Oct 10, 2014
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.32-1.el6.noarch
* candlepin-common-1.0.8-1.el6.noarch
* candlepin-selinux-0.9.32-1.el6.noarch
* candlepin-tomcat6-0.9.32-1.el6.noarch
* elasticsearch-0.90.10-7.el6.noarch
* foreman-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-compute-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-gce-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-libvirt-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-ovirt-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-postgresql-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-proxy-1.7.0-0.develop.201410081229git52f0bac.el6.noarch
* foreman-release-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-selinux-1.7.0-0.develop.201409301113git2f345de.el6.noarch
* foreman-vmware-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* katello-2.1.0-1.201410091751gitc9c45c1.el6.noarch
* katello-certs-tools-2.0.1-1.el6.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-2.1.0-1.201410021645git304e036.el6.noarch
* katello-repos-2.1.1-1.el6.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-docker-plugins-0.2.1-0.2.beta.el6.noarch
* pulp-katello-0.3-3.el6.noarch
* pulp-nodes-common-2.5.0-0.7.beta.el6.noarch
* pulp-nodes-parent-2.5.0-0.7.beta.el6.noarch
* pulp-puppet-plugins-2.5.0-0.7.beta.el6.noarch
* pulp-puppet-tools-2.5.0-0.7.beta.el6.noarch
* pulp-rpm-plugins-2.5.0-0.7.beta.el6.noarch
* pulp-selinux-2.5.0-0.7.beta.el6.noarch
* pulp-server-2.5.0-0.7.beta.el6.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.3.1-1.el6.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6.noarch
* ruby193-rubygem-runcible-1.2.0-1.el6.noarch

Comment 8 Thom Carlin 2015-01-07 19:52:51 UTC
Also, a description field would be tremendously helpful.  Please let me know if this should be split into a separate RFE.

Comment 9 Daniel Lobato Garcia 2015-01-08 10:28:47 UTC
This was merged upstream for 1.7, http://projects.theforeman.org/issues/4369.
I'm not sure why this ticket is still open.

Comment 10 Daniel Lobato Garcia 2015-02-19 07:38:23 UTC
https://sat-perf-04.idm.lab.bos.redhat.com/roles , you can try there clicking on the filters tab. Closing for the time being.

Comment 11 Bryan Kearney 2015-02-19 15:19:57 UTC
*** Bug 1192852 has been marked as a duplicate of this bug. ***

Comment 12 Sachin Ghai 2015-10-20 08:54:15 UTC
Verified with latest upstream build:

foreman-release-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch


when we click on an existing role from the list, I still see the page to edit the name instead of filters tab.  Is it expected ?

As per the original bug description, clicking a role in UI should go to filters page first. Please confirm what should be the expected here ?

Comment 13 Sachin Ghai 2015-10-20 08:58:32 UTC
Created attachment 1084656 [details]
on clicking a role, UI opens page to edit the role name along with filters tab.

Comment 14 Tazim Kolhar 2015-11-20 19:16:29 UTC
VERIFIED:
# rpm -qa  | grep foreman
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-release-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-ovirt-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-libvirt-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-postgresql-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
foreman-debug-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-proxy-1.11.0-0.develop.201511111339git7cbe47a.el7.noarch
foreman-compute-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201511111650gitdda13df.el7.noarch
foreman-gce-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-vmware-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch


steps:
on clicking a role, UI opens page to edit the role name along with filters tab.

Comment 18 errata-xmlrpc 2016-07-27 08:41:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Comment 19 Daniel Lobato Garcia 2016-12-09 10:50:11 UTC
I don't think this really needs info from me anymore


Note You need to log in before you can comment on or make changes to this bug.