Bug 169014 - RFE: include DSDT initrd patch
RFE: include DSDT initrd patch
Status: CLOSED DUPLICATE of bug 110511
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
RFE: include DSDT initrd patch
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2005-09-22 03:15 EDT by Patrick
Modified: 2008-06-24 13:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-28 05:30:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Patrick 2005-09-22 03:15:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
To be able to easily apply and test ACPI DSDT bugfixes I would most appreciate it if you could add the appropriate patch(es) from http://gaugusch.at/kernel.shtml. While I understand Dave Jones' goal to reduce patchcount in FC kernels the DSDT initrd patch is IMHO not a feature but a facilitator to fix DSDT bugs and easily test the fixes. I have an Acer laptop and the DSDT in FC4's 2.6.12-1447 has a pretty annoying battery bug that fills up the console and /var/log/messages. Afaik it only takes about three tweaks like s/Z00I/Z001 to fix it. That's a few minor changes that requires me right now to patch the FC4 kernel src.rpm and rebuild it. I have seen Len Brown's feedback on this subject (http://sourceforge.net/mailarchive/message.php?msg_id=9175150) and I respectfully disagree with him and it seems so do at least Ubuntu, OpenSuSe and Mandriva. I hope you will include the patch in a future FC4/Rawhide kernel release.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. fix DSDT bug
2. patch FC kernel src.rpm
3. rebuild, install, test. if not ok back to 1.

Actual Results:  Should work unless you made an error in which case you can start all over again with this cumbersome process.

Expected Results:  By adding the DSDT initrd patch I can put the new DSDT in the initrd in mere seconds and easily test it without having to patch the kernel and rebuild it.

Additional info:
Comment 1 Doncho N. Gunchev 2005-09-22 08:25:41 EDT
I second that request. I have ACER Aspire 3002NLC and use custom DSDT to get the
battery status and the NIC working. Contacting ACER resulted in nothing, they
claimed they don't sell this model with linux (check yourself - go to
http://www.acer-ee.com/, select products -> Notebooks, click on Aspire 3000 and
scroll down - Linpus Linux). I have FC4 + 2.6.12-1.1454.2.3_FC4.jwltest.17 on it
now, the pre-installed one did not have rpm (it is rpm based), yum or even X.
Comment 2 Dave Jones 2005-09-28 05:30:51 EDT
I've already explained this several times already.
The only way this is going into the fedora kernel is via upstream.

If users start manipulating their DSDTs, and getting panics etc, they file bugs
here, and would 'neglect' to say how they hacked their dsdt's

It's a support nightmare waiting to happen.
Comment 3 Charles R. Anderson 2008-06-24 13:42:48 EDT

*** This bug has been marked as a duplicate of 110511 ***

Note You need to log in before you can comment on or make changes to this bug.