Bug 1105218 - Multi-instance( on Multi-Backend) Dell EqualLogic Cinder Support
Summary: Multi-instance( on Multi-Backend) Dell EqualLogic Cinder Support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ga
: 5.0 (RHEL 7)
Assignee: Jiri Stransky
QA Contact: nlevinki
URL:
Whiteboard:
Depends On: 1094385 1125278 1126562 1132550
Blocks: 1093544 1126563 1132591
TreeView+ depends on / blocked
 
Reported: 2014-06-05 15:35 UTC by Rajini Karthik
Modified: 2016-04-26 18:09 UTC (History)
11 users (show)

Fixed In Version: openstack-foreman-installer-2.0.9-1.el6ost
Doc Type: Enhancement
Doc Text:
This enhancement enables support for multiple instances of the Dell EqualLogic backend for Block Storage (Cinder). As a result, all Dell EqualLogic parameters are now arrays instead of single values, with the exception of 'cinder_backend_eqlx' which remains a true/false switch to enable/disable the EqualLogic backend. In addition, all EqualLogic parameter arrays are expected to have the same number of elements: the first elements of each array form properties of one instance of the EqualLogic backend, while the second elements of each array form properties of another instance. This pattern continues for subsequent elements.
Clone Of:
: 1126563 (view as bug list)
Environment:
Last Closed: 2014-08-04 18:32:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1003 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-04 22:31:07 UTC

Description Rajini Karthik 2014-06-05 15:35:40 UTC
Description of problem:
Dell Red Hat OpenStack Solution need support for multiple instance support on top of multi back end storage for Equallogic Arrays.

Dell team will do the work upstream Astapor to add this support on top of the muti-backend support work

Version-Release number of selected component (if applicable):
OSP 5


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Rajini Karthik 2014-06-05 15:37:06 UTC
This change will be on top of https://bugzilla.redhat.com/show_bug.cgi?id=1094385

Comment 3 Rajini Karthik 2014-06-06 15:36:03 UTC
Will have to create a PR. Waiting for other PRs to be merged.
https://github.com/rajinir/astapor/commit/cd5ea2bc4efe4872a926a3c7f66c49d751dccf63

Comment 4 Rajini Karthik 2014-06-13 19:43:42 UTC
Submitted a PR: https://github.com/redhat-openstack/astapor/pull/268/

Comment 6 Audra Cooper 2014-07-11 15:36:30 UTC
This feature is covered in the following test plan:

https://wiki.opencrowbar.org/pages/worddav/preview.action?fileName=Testplan_OSP5_upd_Jul10.docx&pageId=4491007

Comment 9 arkady kanevsky 2014-07-21 14:03:49 UTC
The related doc for it is - 1114752

Comment 11 errata-xmlrpc 2014-08-04 18:32:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1003.html


Note You need to log in before you can comment on or make changes to this bug.