Bug 1094385 - Multi-Backend Cinder Support
Summary: Multi-Backend Cinder Support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 4.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: 5.0 (RHEL 7)
Assignee: Jiri Stransky
QA Contact: nlevinki
URL:
Whiteboard:
: 1089773 (view as bug list)
Depends On:
Blocks: 1096699 1105218 1125278 1126562 1126563 1132550 1132591
TreeView+ depends on / blocked
 
Reported: 2014-05-05 14:47 UTC by Rajini Karthik
Modified: 2016-04-26 13:45 UTC (History)
16 users (show)

Fixed In Version: openstack-foreman-installer-2.0.6-1.el6ost
Doc Type: Enhancement
Doc Text:
The Block Storage (Cinder) service now supports multiple concurrent back-ends. To enable this feature, set the following Host Group parameters to 'true': * cinder_multiple_backends * cinder_backend_[backend type] (where [backend_type] is each back-end type you wish to enable) You will also need to set values specific to the selected back-ends.
Clone Of:
: 1125278 1126562 (view as bug list)
Environment:
Last Closed: 2014-08-04 18:33:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1003 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-04 22:31:07 UTC

Description Rajini Karthik 2014-05-05 14:47:32 UTC
Description of problem:
Does not directly support multiple storage back-ends. Code changes have to made to the quickstack manifest, packstack/puppet-modules and OSP to support enabled_backends config parameter.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
There is a pull-request submitted to enable backends gluster, ISCSI and Dell Equalogic
https://github.com/redhat-openstack/astapor/pull/210

Comment 2 Sean Cohen 2014-05-07 12:42:37 UTC
Multi-Backend Support for Cinder and Dell EqualLogic support seems to be in place as of May 2, 2014 (https://review.openstack.org/#/c/89602/) 

Moving to packstack component 
Sean

Comment 3 Rajini Karthik 2014-05-22 18:39:32 UTC
Astapor pull request for the changes required for this are patched and now ready to be merged
https://github.com/redhat-openstack/astapor/pull/210

Comment 4 arkady kanevsky 2014-06-05 14:19:27 UTC
*** Bug 1089773 has been marked as a duplicate of this bug. ***

Comment 6 arkady kanevsky 2014-06-13 14:28:13 UTC
Jason, do we have a fix for RHEL7.0?

Comment 7 Jiri Stransky 2014-06-16 08:19:44 UTC
Got merged upstream as part of https://github.com/redhat-openstack/astapor/pull/259

Comment 10 Audra Cooper 2014-07-11 15:35:39 UTC
This feature is covered in the following test plan:

https://wiki.opencrowbar.org/pages/worddav/preview.action?fileName=Testplan_OSP5_upd_Jul10.docx&pageId=4491007

Comment 14 errata-xmlrpc 2014-08-04 18:33:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1003.html


Note You need to log in before you can comment on or make changes to this bug.