Bug 1132550 - Multi-Backend Cinder Support
Summary: Multi-Backend Cinder Support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 4.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z1
: Installer
Assignee: Jiri Stransky
QA Contact: Yogev Rabl
URL: https://trello.com/c/dLT8Wbs6
Whiteboard: MVP
Depends On: 1094385 1125278 1126562
Blocks: 1096699 1105218 1108193 1126563 1132591
TreeView+ depends on / blocked
 
Reported: 2014-08-21 14:25 UTC by Scott Lewis
Modified: 2016-04-26 14:38 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1125278
Environment:
Last Closed: 2014-10-02 12:56:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Comment 3 Yogev Rabl 2014-09-18 12:13:04 UTC
Verification failed due to Bug 1143986.

Comment 4 Mike Burns 2014-09-18 13:50:52 UTC
The fact that the UI failed, doesn't mean the puppet fails.  moving back to ON_QA.  It can remain in on_qa but verification blocked, it doesn't need to be pushed back to engineering for a fix.

Comment 5 arkady kanevsky 2014-09-18 16:10:23 UTC
Rajini,
can you, please, comment on it?
Not sure if you used latest Staypuft bits for deployment.
But you had tested multi-backend cinder functionality.
Arkady

Comment 6 Rajini Karthik 2014-09-18 17:13:11 UTC
I tested StayPuft/OSP5 bits and verified that multibackend cinder support works with LVM and Ceph. If the volume_driver is not specified, it will default to LVMISCSIDriver and it worked fine.

This is the staypuft version I tested 
ruby193-rubygem-staypuft-0.2.6-1.el6ost.noarch

Comment 7 Rajini Karthik 2014-09-18 17:13:55 UTC
IMO this is not a bug. This is how it was working before for single backend as well. It is a nice to have feature.

Comment 9 Yogev Rabl 2014-09-29 07:35:50 UTC
From my POV, this feature is not fully ready, so it is not verification failed.

Comment 10 Mike Burns 2014-09-29 11:14:07 UTC
Multi-backend is configured and works with the current settings.  Adding the missing driver setting can be split off into another bz for a future version, but does not impact whether this was delivered.

Comment 11 Yogev Rabl 2014-09-29 11:43:09 UTC
I disagree. The multiple back end is designed with the option that the user can create a volume and set the back end manually, it is part of this feature core elements.
Without the type configuration the multiple back end feature is not available to the users/operators as it was designed, thus this bug is not fully fixed.

Comment 17 Scott Lewis 2014-10-02 12:56:30 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.