Bug 1105716 - [RFE] "Product Content" tab shows content sets not applicable to the content host
Summary: [RFE] "Product Content" tab shows content sets not applicable to the content ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: FutureFeature, Triaged
: 1106466 1402794 (view as bug list)
Depends On: 1314884
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2014-06-06 19:28 UTC by Tom McKay
Modified: 2018-03-22 19:46 UTC (History)
6 users (show)

(edit)
The product content repository sets displayed for enable and disable overrides may show content that will never be available on the registered client host. For example, kickstart content will never appear in the host's redhat.repo file but it is listed in the UI. The logic built into the subscription-manager (or RHSM? not sure of best term?) is not replicated in the Satellite server code.
Clone Of:
(edit)
Last Closed: 2018-03-22 19:46:57 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6104 None None None 2016-04-22 15:44 UTC

Description Tom McKay 2014-06-06 19:28:34 UTC
Having both 6Server and 5Server content sets available under a subscription means that both will show up on the content host's "Product Content" tab. The redhat.repo file, however, will only be populated with the content set that matches its version (eg. just the 6Server content will show up in the redhat.repo file on a 6Server host). Kickstart content sets also are displayed when they too will not be in the redhat.repo.

Candlepin needs to provide a mechanism to query what the redhat.repo file really looks like on the client.

Comment 1 Tom McKay 2014-06-06 19:28:35 UTC
Created from redmine issue http://projects.theforeman.org/issues/6104

Comment 3 Tom McKay 2014-06-09 12:39:57 UTC
*** Bug 1106466 has been marked as a duplicate of this bug. ***

Comment 5 Bryan Kearney 2015-08-25 17:24:03 UTC
Upstream bug component is Candlepin

Comment 6 Tom McKay 2016-12-12 14:15:04 UTC
*** Bug 1402794 has been marked as a duplicate of this bug. ***

Comment 7 Bryan Kearney 2018-03-22 19:46:57 UTC
This was addressed in Satellite 6.3 by adding the ability to limit views. IF you have upgraded to 6.3 and you are still seeing this, pelase feel free to re-open with additional information.


Note You need to log in before you can comment on or make changes to this bug.