Bug 1110646 - woff file missing on purpose?
Summary: woff file missing on purpose?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fontawesome-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-18 06:58 UTC by Thomas Spura
Modified: 2017-08-16 11:21 UTC (History)
6 users (show)

Fixed In Version: fontawesome-fonts-4.1.0-2.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-16 11:21:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1476689 None CLOSED jpype - new version 0.6.2 available 2019-03-02 10:31:10 UTC

Internal Links: 1476689 1492884

Description Thomas Spura 2014-06-18 06:58:54 UTC
Description of problem:
ipython shows this warning:
2014-06-16 20:47:56.421 [tornado.access] WARNING | 404 GET /static/components/font-awesome/font/fontawesome-webfont.woff?v=3.2.1 (127.0.0.1) 0.37ms referer=http://localhost:8888/static/style/style.min.css?v=7775081fa91df3822d16b2087bc2c8dd

Would it be possible to also add the .woff file to fontawesome-webfont-web or is it left out on purpose?

How reproducible:
always

Steps to Reproduce:
1. open ipython-notebook

Actual results:
no fontawesome-webfont.woff

Expected results:
fontawesome-webfont.woff

See also #1006575 for the ipython warning above.

Comment 1 Petr Vobornik 2014-06-18 07:55:52 UTC
It was intentionally left out from fontawesome-fonts package because of fedora fonts packaging policy.

I'm actually not sure if it would be OK to include it (and .eot, .svg variants) to the *-web package. If so, it would also require a symlink or something to the .ttf file otherwise the .ttf link would be broken. 

The *-web package might require even more love. For instance the directory name with version in it is not really good. 

Also the "css" dir should probably be in "/usr/share/web-assets/fontawesome" [1].

If it's possible, I suggest to use font definition as follows:

@font-face {
  font-family: 'FontAwesome';
  src:  url('@{fa-font-path}/fontawesome-webfont.ttf?v=@{fa-version}') format('truetype');
  font-weight: normal;
  font-style: normal;
}

I'm open to suggestions to make the packaging right.

[1] http://fedoraproject.org/wiki/Changes/Web_Assets

Comment 2 Thomas Spura 2014-06-18 08:36:50 UTC
(In reply to Petr Vobornik from comment #1)
> It was intentionally left out from fontawesome-fonts package because of
> fedora fonts packaging policy.

ok. Didn't know that.

> I'm actually not sure if it would be OK to include it (and .eot, .svg
> variants) to the *-web package. If so, it would also require a symlink or
> something to the .ttf file otherwise the .ttf link would be broken. 
> 
> The *-web package might require even more love. For instance the directory
> name with version in it is not really good. 
> 
> Also the "css" dir should probably be in "/usr/share/web-assets/fontawesome"
> [1].
> 
> If it's possible, I suggest to use font definition as follows:
> 
> @font-face {
>   font-family: 'FontAwesome';
>   src:  url('@{fa-font-path}/fontawesome-webfont.ttf?v=@{fa-version}')
> format('truetype');
>   font-weight: normal;
>   font-style: normal;
> }

ipython has a .less file and seems to generate a .min.css file from that.
I'll need to see to maybe regenerate the .min.css file, then your suggestion from above should be "found" automatically. As they currently have that woff file around, the .min.css generating script seems to automatically at it too.

Thanks!

I guess this can be closed then, if the woff file is indeed missing on purpose...

Comment 3 Fedora Update System 2014-12-06 18:58:52 UTC
fontawesome-fonts-4.1.0-2.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/fontawesome-fonts-4.1.0-2.el7

Comment 4 Fedora Update System 2014-12-06 18:59:23 UTC
fontawesome-fonts-4.1.0-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/fontawesome-fonts-4.1.0-2.fc21

Comment 5 Fedora Update System 2014-12-12 04:13:14 UTC
fontawesome-fonts-4.1.0-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2015-01-04 20:07:36 UTC
fontawesome-fonts-4.1.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Bryce Nordgren 2015-02-26 20:19:30 UTC
On Fedora 21, I'm getting:

WARNING:tornado.access:404 GET /static/fonts/fontawesome-webfont.ttf?v=4.1.0 

package fontawesome-fonts-4.1.0-2.fc21. More information on stackoverflow question (because I'm not certain whether the fault is in the packaging or the software...): http://stackoverflow.com/questions/28733313/ipython-notebook-2-3-0-on-fedora-21-cannot-find-fontawesome 

This is not precisely the same error, but seems related. Shall I file a new bug or shall we continue here?

Comment 8 Matthias Runge 2015-02-27 06:54:34 UTC
Bryce, I can confirm, this issue is now fixed with OpenStack Horizon.

@tomspur, can you comment here?

Comment 9 Thomas Spura 2015-02-27 08:51:25 UTC
It seems to work fine over here.

What is the output of:
rpm -qa | grep ipython | sort

and
ls -l /usr/lib/python?.?/site-packages/IPython/html/static/components/font-awesome/font{,/}

Comment 10 Bryce Nordgren 2015-02-27 17:28:57 UTC
(In reply to Thomas Spura from comment #9)
> It seems to work fine over here.
> 
> What is the output of:
> rpm -qa | grep ipython | sort

[fedora@lugosi ~]$ rpm -qa | grep ipython | sort
python-ipython-console-2.3.0-1.fc21.noarch
python-ipython-notebook-2.3.0-1.fc21.noarch


> 
> and
> ls -l
> /usr/lib/python?.?/site-packages/IPython/html/static/components/font-awesome/
> font{,/}

[fedora@lugosi ~]$ ls -l /usr/lib/python?.?/site-packages/IPython/html/static/components/font-awesome/font{,/}
lrwxrwxrwx. 1 root root   28 Nov 15 00:09 /usr/lib/python2.7/site-packages/IPython/html/static/components/font-awesome/font -> /usr/share/fonts/fontawesome

/usr/lib/python2.7/site-packages/IPython/html/static/components/font-awesome/font/:
total 548
-rw-r--r--. 1 root root  75188 Jul  3  2014 FontAwesome.otf
-rw-r--r--. 1 root root 253487 Jul  3  2014 fontawesome-webfont.svg
-rw-r--r--. 1 root root 141564 Dec  5 13:37 fontawesome-webfont.ttf
-rw-r--r--. 1 root root  83760 Jul  3  2014 fontawesome-webfont.woff

Comment 11 Bryce Nordgren 2015-03-02 20:27:30 UTC
Just curious if I should create a new bug against the ipython fedora package?

Comment 12 Thomas Spura 2015-03-16 11:06:55 UTC
Yes, please open a new bug against ipython.

I think this was working in 2.2, but with the recent update to 2.3 it seems the notbook broke unfortunately...

Comment 13 Raphael Groner 2017-08-16 11:13:49 UTC
I'll reopen this bug because the mentioned changes breaks execution of sphinx to generate documentation in RHEL7.

Error: [('/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.svg', '/builddir/build/BUILD/jpype-0.6.2/html/_static/fonts/fontawesome-webfont.svg', "[Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.svg'"), ('/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.woff', '/builddir/build/BUILD/jpype-0.6.2/html/_static/fonts/fontawesome-webfont.woff', "[Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.woff'"), ('/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.eot', '/builddir/build/BUILD/jpype-0.6.2/html/_static/fonts/fontawesome-webfont.eot', "[Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.eot'")]
The full traceback has been saved in /tmp/sphinx-err-5erdKL.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
Either send bugs to the mailing list at <http://groups.google.com/group/sphinx-dev/>,
or report them in the tracker at <http://bitbucket.org/birkenfeld/sphinx/issues/>. Thanks!

https://koji.fedoraproject.org/koji/taskinfo?taskID=21258667

For reproducibility, you can try to build e.g. jpype from old git (disabled sphinx in HEAD):
https://src.fedoraproject.org/rpms/jpype/c/1163c5afa3b2eee812096ba2520361646edc0c44?branch=epel7

Please let me know if I should report this issue to Red Hat service.

Comment 14 Matthias Runge 2017-08-16 11:21:02 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1110646#c13 has nothing to do with the rest of this bug. If you think, you have an issue, please report a new bug. Thank you.


Note You need to log in before you can comment on or make changes to this bug.