Bug 1492884 - fontawesome-fonts-web doesn't include SVG or WOFF files, breaking many EPEL doc builds
Summary: fontawesome-fonts-web doesn't include SVG or WOFF files, breaking many EPEL d...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fontawesome-fonts
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Petr Vobornik
QA Contact: QE Internationalization Bugs
URL:
Whiteboard: PrioritizedBug
Depends On: 1592856
Blocks: 1497654 1514181 1459712
TreeView+ depends on / blocked
 
Reported: 2017-09-18 20:40 UTC by Eli Young
Modified: 2018-10-30 11:22 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-10-30 11:22:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1110646 None CLOSED woff file missing on purpose? 2018-12-11 00:19:04 UTC
Red Hat Product Errata RHBA-2018:3217 None None None 2018-10-30 11:22:44 UTC

Description Eli Young 2017-09-18 20:40:14 UTC
Description of problem:
The release of RHEL 7.4 added packages for fontawesome-fonts and fontawesome-fonts-web. As a result, these packages were removed from EPEL. A number of projects use the python-sphinx_rtd_theme package to build their documentation, which has a dependency on fontawesome-fonts-web and uses the SVG and WOFF files it provides. Unfortunately, the fontawesome-fonts-web package provided by RHEL 7.4 appears to have been forked from the upstream Fedora repository at [1], which does not include the WOFF or SVG files, causing build failures such as [2] and [3]. For Fedora, this issue was brought up as #1110646 and fixed in the following commit [4], but this was not included in the RHEL 7.4 release. Backporting this fix would resolve many build issues in EPEL that currently must be resolved by disabling documentation building.

Version-Release number of selected component (if applicable):
4.1.0-1.el7

How reproducible:
Trivial.

Steps to Reproduce:
1. Attempt to build certbot from commit: http://pkgs.fedoraproject.org/cgit/rpms/certbot.git/commit/?id=5cdf97972af7c7721e3b99d03bf5e372ca30916f

Actual results:
Build fails with the following error:

Exception occurred:
  File "/usr/lib64/python2.7/shutil.py", line 208, in copytree
    raise Error, errors
Error: [('/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.svg', '/builddir/build/BUILD/acme-0.18.1/docs/_build/html/_static/fonts/fontawesome-webfont.svg', "[Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.svg'"), ('/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.woff', '/builddir/build/BUILD/acme-0.18.1/docs/_build/html/_static/fonts/fontawesome-webfont.woff', "[Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/sphinx_rtd_theme/static/fonts/fontawesome-webfont.woff'")]

Expected results:
Build succeeds.

Additional info:

[1]: http://pkgs.fedoraproject.org/cgit/rpms/fontawesome-fonts.git/commit/?id=8a36c79495ee56589b04e712d01354d74d5b0787
[2]: https://bugzilla.redhat.com/show_bug.cgi?id=1476689#c3
[3]: https://koji.fedoraproject.org/koji/buildinfo?buildID=968965
[4]: http://pkgs.fedoraproject.org/cgit/rpms/fontawesome-fonts.git/commit/?id=8a36c79495ee56589b04e712d01354d74d5b0787

Comment 2 Eli Young 2017-09-19 02:00:51 UTC
Correction to the reproduction steps:
1. Attempt to build python-acme from commit: http://pkgs.fedoraproject.org/cgit/rpms/python-acme.git/commit/?h=epel7

Comment 3 Matt Dainty 2017-09-19 08:45:22 UTC
Just found the same issue, trying to build the same updated python-acme package independently :-)

I initially thought the difference was down to CentOS vs RHEL as it was working on an internal RHEL host but this was down to having an internal mirror of EPEL which still contained the 4.1.0-2 package.

Incidentally, shouldn't the package release in 7.4 be at least 4.1.0-2 or 4.1.0-3 otherwise any host that has the EPEL package installed will never consider the package in 7.4 an update?

Comment 4 Eli Young 2017-09-21 22:41:39 UTC
Correction to the correction URL: http://pkgs.fedoraproject.org/cgit/rpms/python-acme.git/commit/?h=epel7&id=4fb3e9ce32ab2cd16993ef56ccdd3b3fb536cfb0

Somehow I managed to exclude an actual commit hash, which is kind of important.

Comment 5 Scott K Logan 2017-11-06 02:18:41 UTC
This is still a problem, and is blocking at least one of my package updates.

Comment 6 Piotr Popieluch 2017-11-16 20:45:45 UTC
Petr, anything you can do about this. It seems to affect many packages.

bug 1514181 bug 1461798 bug 1282296

Comment 7 Petr Vobornik 2017-11-22 17:37:56 UTC
Hello Piotr,

font-awesome fonts were introduced in RHEL 7.1. It matched the version in Fedora. The package was not updated on RHEL since then. It was updated on Fedora and its EPEL branch. One of the Fedora updates added the woff and svg fonts. Later it was removed from EPEL - which was basically a downgrade. I.e. seems to me like EPEL policy issue.

IMO it would be better to have newer version in EPEL given that except for this bug I don't remember any request to update this package.

Alternatively, open a support case with Red Hat to expedite the change on RHEL.

Comment 8 Eli Young 2017-11-22 18:07:19 UTC
While the fontawesome-fonts package was introduced in RHEL 7.1, the fontawesome-fonts-web package was introduced in RHEL 7.4. It was renewed from EPEL, and cannot be reintroduced, because EPEL has a policy against providing packages that conflict with or update upstream packages. From [1]:

> Thus packages from EPEL should never replace packages from the target base distribution - including those on the base distribution as well as layered products[...]

As such, this fix needs to come from upstream.

[1]: https://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies#Policy

Comment 9 Eli Young 2017-11-29 20:35:54 UTC
(In reply to Petr Vobornik from comment #7)
> Alternatively, open a support case with Red Hat to expedite the change on
> RHEL.

I'd do this myself, but I don't have a subscription with support. Is there any other way to get this expedited in RHEL? Alternatively, could someone else who has a support subscription open a case? This bug is causing numerous issues with building documentation in EPEL packages, and has to be fixed upstream for reasons explained in my previous comment.

Comment 10 Tomas Krizek 2018-01-23 15:23:15 UTC
knot-resolver-doc package also depends on sphinx_rtd_theme and can't be built for EPEL7 until this bug is resolved.

Comment 11 Matthew Miller 2018-01-23 21:53:59 UTC
Petr, by policy, EPEL can't override RHEL packages, so that route is out. On the other hand, this isn't really a customer support issue -- but it's an issue which makes life difficult for volunteers providing software used to enhance RHEL by many, many customers. Can we figure out a way to solve this?

Comment 12 Nick Bebout 2018-01-23 22:46:28 UTC
Nominating for the Fedora Prioritized Bug List so maybe this can get some attention.

Comment 13 Nick Bebout 2018-02-05 16:11:52 UTC
Petr, this is breaking several packages.  Please fix this.  We can't update EPEL because that would replace the version in RHEL.....

Comment 17 Jason Tibbitts 2018-03-30 01:19:27 UTC
EPEL could provide a package (with a different name, of course) which just includes the missing files and depends on the RHEL package.  This would mean that packages which need those files would have to grow an extra dependency on EPEL or some other dep like a magic virtual provide would have to be used (or even, horror, a file dependency) but it would simply and easily work around the problem until the vast RHEL machinery grinds out an update.

Comment 23 Nikhil Dehadrai 2018-09-06 07:54:24 UTC
Versions:
ipa-server-4.6.4-8.el7.x86_64
fontawesome-fonts-web.noarch 0:4.1.0-2.el7 


Verified the bug on the basis of below observations:

[root@vm-idm-011 ~]# rpm -q ipa-server
ipa-server-4.6.4-8.el7.x86_64

[root@vm-idm-011 ~]# ls -l /usr/share/fonts/fontawesome/
total 216
-rw-r--r--. 1 root root  75188 Jul  4  2014 FontAwesome.otf
-rw-r--r--. 1 root root 141564 Aug  1 17:53 fontawesome-webfont.ttf

[root@vm-idm-011 ~]# yum install fontawesome-fonts-web
Loaded plugins: product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
beaker-Server                                                                                   | 4.3 kB  00:00:00     
beaker-Server-HighAvailability                                                                  | 4.3 kB  00:00:00     
beaker-Server-NFV                                                                               | 3.8 kB  00:00:00     
beaker-Server-NFV-debuginfo                                                                     | 3.0 kB  00:00:00     
beaker-Server-RT                                                                                | 4.2 kB  00:00:00     
beaker-Server-RT-debuginfo                                                                      | 3.0 kB  00:00:00     
beaker-Server-ResilientStorage                                                                  | 4.3 kB  00:00:00     
beaker-Server-SAP                                                                               | 4.2 kB  00:00:00     
beaker-Server-SAP-debuginfo                                                                     | 3.0 kB  00:00:00     
beaker-Server-SAPHANA                                                                           | 4.2 kB  00:00:00     
beaker-Server-SAPHANA-debuginfo                                                                 | 3.0 kB  00:00:00     
beaker-Server-debuginfo                                                                         | 3.0 kB  00:00:00     
beaker-Server-optional                                                                          | 3.8 kB  00:00:00     
beaker-Server-optional-debuginfo                                                                | 3.0 kB  00:00:00     
beaker-harness                                                                                  | 1.3 kB  00:00:00     
beaker-tasks                                                                                    | 1.3 kB  00:00:00     
ipa-76c                                                                                         | 2.6 kB  00:00:00     
ipa-76c/primary_db                                                                              | 5.6 MB  00:00:05     
Resolving Dependencies
--> Running transaction check
---> Package fontawesome-fonts-web.noarch 0:4.1.0-2.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================================
 Package                           Arch               Version                 Repository                          Size
=======================================================================================================================
Installing:
 fontawesome-fonts-web             noarch             4.1.0-2.el7             beaker-Server-optional             249 k

Transaction Summary
=======================================================================================================================
Install  1 Package

Total download size: 249 k
Installed size: 545 k
Is this ok [y/d/N]: y
Downloading packages:
fontawesome-fonts-web-4.1.0-2.el7.noarch.rpm                                                    | 249 kB  00:00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : fontawesome-fonts-web-4.1.0-2.el7.noarch                                                            1/1 
  Verifying  : fontawesome-fonts-web-4.1.0-2.el7.noarch                                                            1/1 

Installed:
  fontawesome-fonts-web.noarch 0:4.1.0-2.el7                                                                           

Complete!


[root@vm-idm-011 ~]# ls -l /usr/share/fonts/fontawesome/
total 620
-rw-r--r--. 1 root root  75188 Jul  4  2014 FontAwesome.otf
-rw-r--r--. 1 root root  72449 Jul  4  2014 fontawesome-webfont.eot
-rw-r--r--. 1 root root 253487 Jul  4  2014 fontawesome-webfont.svg
-rw-r--r--. 1 root root 141564 Aug  1 17:53 fontawesome-webfont.ttf
-rw-r--r--. 1 root root  83760 Jul  4  2014 fontawesome-webfont.woff

[root@vm-idm-011 ~]# rpm -ql fontawesome-fonts-web
/usr/share/font-awesome-web
/usr/share/font-awesome-web/css
/usr/share/font-awesome-web/css/font-awesome.css
/usr/share/font-awesome-web/css/font-awesome.min.css
/usr/share/font-awesome-web/less
/usr/share/font-awesome-web/less/bordered-pulled.less
/usr/share/font-awesome-web/less/core.less
/usr/share/font-awesome-web/less/fixed-width.less
/usr/share/font-awesome-web/less/font-awesome.less
/usr/share/font-awesome-web/less/icons.less
/usr/share/font-awesome-web/less/larger.less
/usr/share/font-awesome-web/less/list.less
/usr/share/font-awesome-web/less/mixins.less
/usr/share/font-awesome-web/less/path.less
/usr/share/font-awesome-web/less/rotated-flipped.less
/usr/share/font-awesome-web/less/spinning.less
/usr/share/font-awesome-web/less/stacked.less
/usr/share/font-awesome-web/less/variables.less
/usr/share/font-awesome-web/scss
/usr/share/font-awesome-web/scss/_bordered-pulled.scss
/usr/share/font-awesome-web/scss/_core.scss
/usr/share/font-awesome-web/scss/_fixed-width.scss
/usr/share/font-awesome-web/scss/_icons.scss
/usr/share/font-awesome-web/scss/_larger.scss
/usr/share/font-awesome-web/scss/_list.scss
/usr/share/font-awesome-web/scss/_mixins.scss
/usr/share/font-awesome-web/scss/_path.scss
/usr/share/font-awesome-web/scss/_rotated-flipped.scss
/usr/share/font-awesome-web/scss/_spinning.scss
/usr/share/font-awesome-web/scss/_stacked.scss
/usr/share/font-awesome-web/scss/_variables.scss
/usr/share/font-awesome-web/scss/font-awesome.scss
/usr/share/fonts/fontawesome/fontawesome-webfont.eot
/usr/share/fonts/fontawesome/fontawesome-webfont.svg
/usr/share/fonts/fontawesome/fontawesome-webfont.woff
[root@vm-idm-011 ~]#

Thus on the basis of above observations, marking the status of bug to 'VERIFIED'.

Comment 25 errata-xmlrpc 2018-10-30 11:22:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3217


Note You need to log in before you can comment on or make changes to this bug.