Bug 1110861 - Unable to set default organization for a user during user creation in Any Context mode
Summary: Unable to set default organization for a user during user creation in Any Con...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Daniel Lobato Garcia
QA Contact: sthirugn@redhat.com
URL:
Whiteboard:
Keywords: Reopened, Triaged
Depends On: 1112346
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-18 15:43 UTC by sthirugn@redhat.com
Modified: 2014-09-11 12:26 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-09-11 12:26:58 UTC


Attachments (Terms of Use)

Description sthirugn@redhat.com 2014-06-18 15:43:28 UTC
Description of problem:
Unable to set default organization for a user during user creation in Any Context mode

Version-Release number of selected component (if applicable):
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.17-1.el6sat.noarch
* foreman-compute-1.6.0.17-1.el6sat.noarch
* foreman-gce-1.6.0.17-1.el6sat.noarch
* foreman-libvirt-1.6.0.17-1.el6sat.noarch
* foreman-ovirt-1.6.0.17-1.el6sat.noarch
* foreman-postgresql-1.6.0.17-1.el6sat.noarch
* foreman-proxy-1.6.0.7-1.el6sat.noarch
* foreman-selinux-1.6.0-4.el6sat.noarch
* foreman-vmware-1.6.0.17-1.el6sat.noarch
* katello-1.5.0-26.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.48-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.20.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.20.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.20.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.20.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.20.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.20.beta.el6sat.noarch
* pulp-server-2.4.0-0.20.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Satellite UI -> 'Any Context' mode
2. Click on 'New User'

Actual results:
Default Location and Default Organization dropdowns are empty

Expected results:
There are two options:
1. Default Location and Default Organization dropdown should have proper values
2. (or) Remove both the dropdowns from here and move them to Locations or Organizations Tab respectively.

Additional info:

Comment 2 Bryan Kearney 2014-06-18 16:08:51 UTC
Is this the same as https://bugzilla.redhat.com/show_bug.cgi?id=1070638 ?

Comment 3 sthirugn@redhat.com 2014-06-18 17:25:06 UTC
(In reply to Bryan Kearney from comment #2)
> Is this the same as https://bugzilla.redhat.com/show_bug.cgi?id=1070638 ?

No this is different.

Comment 4 Daniel Lobato Garcia 2014-06-25 00:54:45 UTC
Oddly enough I can reproduce this with my regular Chrome browser, the file 'users.js' is not loaded which is the source of the problem. However on Chrome anoymous and Firefox the file is loaded properly and this bug doesn't occur. To be investigated.

Comment 5 Dominic Cleal 2014-06-25 09:48:54 UTC

*** This bug has been marked as a duplicate of bug 1112346 ***

Comment 6 sthirugn@redhat.com 2014-06-25 13:39:01 UTC
(In reply to Daniel Lobato Garcia from comment #4)
> Oddly enough I can reproduce this with my regular Chrome browser, the file
> 'users.js' is not loaded which is the source of the problem. However on
> Chrome anoymous and Firefox the file is loaded properly and this bug doesn't
> occur. To be investigated.

It fails for me in Chrome 27.0.1453.93

Comment 7 sthirugn@redhat.com 2014-06-25 13:40:17 UTC
Disagree with closing this as a duplicate of bug 1112346.  This bug happens in the new user creation page itself. Please see the bug description which is different from bug 1112346.  Also please note that there is no firebug error noticed here in this scenario. Reopening the bug.

Comment 8 Daniel Lobato Garcia 2014-06-26 10:41:53 UTC
sthirugn, patch has been submitted downstream*, anyway even if the descriptions are different, the underlying problem is the same (users.js not being loaded properly in the two-pane view), so https://bugzilla.redhat.com/show_bug.cgi?id=1112346 fixes this.

*:http://projects.theforeman.org/issues/6357

Comment 9 sthirugn@redhat.com 2014-06-26 13:02:01 UTC
@Daniel, Thank you.  I will keep this open and VERIFY once this is available in a downstream build.

Comment 11 sthirugn@redhat.com 2014-09-03 19:02:40 UTC
Verified.

Test Scenario:
1. Go to new User page in Any Context mode - Notice that the Default Location and Default Organization are empty.  
2. Go to Locations tab and add few locations.
3. Go to Organizations tab and add few Orgs.N
4. Go back to User tab, the dropdown is populated.



Version Tested:
GA Snap 7 - Satellite-6.0.4-RHEL-6-20140829.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.42-1.el6sat.noarch
* foreman-compute-1.6.0.42-1.el6sat.noarch
* foreman-gce-1.6.0.42-1.el6sat.noarch
* foreman-libvirt-1.6.0.42-1.el6sat.noarch
* foreman-ovirt-1.6.0.42-1.el6sat.noarch
* foreman-postgresql-1.6.0.42-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.42-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.62-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* openldap-devel-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
* pulp-server-2.4.1-0.5.rc1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

Comment 12 Bryan Kearney 2014-09-11 12:26:58 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.