Bug 1099797 - Satellite Web UI broken links and branding issues: e.g. manual "Useful template functions and macros"
Summary: Satellite Web UI broken links and branding issues: e.g. manual "Useful templ...
Keywords:
Status: CLOSED DUPLICATE of bug 1112399
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
medium
high vote
Target Milestone: Unspecified
Assignee: Dmitri Dolguikh
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1107720 1116148 1119904 1125451 1131138 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker sat6-branding
TreeView+ depends on / blocked
 
Reported: 2014-05-21 08:22 UTC by Martin Korbel
Modified: 2018-12-06 16:34 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-03 08:31:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1112399 0 medium CLOSED Satellite 6 Default Landing Page branding issues: link to product documentation instead of upstream, and use "Red Hat Sa... 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1129393 0 high CLOSED Branding: Some error pages still point to foreman redmine 2021-02-22 00:41:40 UTC

Internal Links: 1112399 1129393

Description Martin Korbel 2014-05-21 08:22:12 UTC
Description of problem:
Broken link into manual "Useful template functions and macros" on the page "Provisioning Templates" https://<fqdn>/config_templates. the link in the notice box (http://www.theforeman.org/manuals/1.6/index.html#4.4.3ProvisioningTemplates).
Correct link is http://www.theforeman.org/manuals/1.5/index.html#4.4.3ProvisioningTemplates.
I don't know, if you are planning new version of foreman, but currently the link doesn't work.


Version-Release number of selected component (if applicable):
katello-1.5.0-24.el6sat

How reproducible:
100%

Steps to Reproduce:
1. Open page Hosts > Provisioning Templates > New Template
2. Click on the link "Useful template functions and macros"

Actual results:
E404 - http://www.theforeman.org/manuals/1.6/index.html#4.4.3ProvisioningTemplates

Expected results:
http://www.theforeman.org/manuals/1.5/index.html#4.4.3ProvisioningTemplates

Additional info:

Comment 1 Dominic Cleal 2014-05-21 08:40:41 UTC
This is expected as Foreman 1.6 is unreleased and documentation hasn't yet been prepared.  Whether Satellite 6 should be linking to such documentation is another matter in my opinion.

Comment 2 RHEL Program Management 2014-05-21 08:45:47 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Dominic Cleal 2014-05-23 13:32:40 UTC
Created redmine issue http://projects.theforeman.org/issues/5912 from this bug

Comment 5 jmagen@redhat.com 2014-05-27 12:17:50 UTC
https://github.com/theforeman/foreman/pull/1480

Comment 6 Dominic Cleal 2014-06-10 13:11:24 UTC
*** Bug 1107720 has been marked as a duplicate of this bug. ***

Comment 10 Dominic Cleal 2014-07-07 07:34:51 UTC
*** Bug 1116148 has been marked as a duplicate of this bug. ***

Comment 12 Xixi 2014-07-16 21:23:49 UTC
*** Bug 1119904 has been marked as a duplicate of this bug. ***

Comment 13 Dominic Cleal 2014-08-01 06:39:43 UTC
*** Bug 1125451 has been marked as a duplicate of this bug. ***

Comment 17 Dominic Cleal 2014-08-18 14:14:41 UTC
*** Bug 1131138 has been marked as a duplicate of this bug. ***

Comment 19 Dominic Cleal 2014-09-03 08:31:19 UTC
Bug #1112399 fixed many instances, bug #1136443 remains open to fix some more.

Bug #1129393 remains open about linking to upstream bug trackers.

Please file any remaining issues as new BZs, but for now I'm going to close this as it's been mostly implemented.

*** This bug has been marked as a duplicate of bug 1112399 ***


Note You need to log in before you can comment on or make changes to this bug.