Bug 1119382 - RFE: Need an option to exclude network IP's when creating Nova networks
Summary: RFE: Need an option to exclude network IP's when creating Nova networks
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: Installer
Assignee: Scott Seago
QA Contact: Omri Hochman
URL:
Whiteboard: MVP
: 1119945 (view as bug list)
Depends On:
Blocks: 1093544 1108193 1119945 1127404 1127405
TreeView+ depends on / blocked
 
Reported: 2014-07-14 16:10 UTC by Kurt Hey
Modified: 2016-04-26 20:33 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
If the networks used for Nova flat/floating ip addresses have specific addresses in the specified range that should not be handed out by Nova, they need to be explicitly removed via a Nova API command following deployment of RHEL OSP. TBD: Need to add an example command here to show how to remove an ip address
Clone Of:
: 1119945 1127404 1127405 (view as bug list)
Environment:
Last Closed: 2014-11-25 19:48:59 UTC


Attachments (Terms of Use)

Description Kurt Hey 2014-07-14 16:10:38 UTC
Description of problem:


Version-Release number of selected component (if applicable):
OSP5 Foreman UI running on RHEL 7

How reproducible:
Everytime

Steps to Reproduce:
1. Install RHEL 7 and then install foreman using the foreman_server.sh script
2. Configure the Controller (Nova Network) and deploy to the Controller Node)
3. Configure the Compute (Nova Network)

Actual results:
When configuring the Floating and Fixed network Ranges, there isn't an option to exclude IP's to avoid stepping on IP's already defined in the switching infrastructure, e.g. Gatetways.  

Expected results:
There should be an additional box that allows the user to exclude specific IP's from being allocated in both the fixed and floating networks.

Additional info:

Comment 3 Mike Burns 2014-08-05 17:12:00 UTC
Just a note, this bug mentions foreman_server.sh which is not supported and mentions installing foreman on RHEL 7 which is not supported.  

We currently support installing using rhel-osp-installer on RHEL 6 (and then deploy RHEL-OSP onto RHEL 7).

That being said, we don't have any UI to add these options, so marking this as an RFE.

Comment 4 Mike Burns 2014-08-05 17:21:11 UTC
*** Bug 1119945 has been marked as a duplicate of this bug. ***

Comment 5 Mike Burns 2014-08-05 20:28:41 UTC
Russell, is this even doable with nova currently

Comment 6 Russell Bryant 2014-08-06 13:29:18 UTC
(In reply to Mike Burns from comment #5)
> Russell, is this even doable with nova currently

Kind of.  You can add individual floating IPs instead of adding a subnet of floating IPs.  So, you can take a subnet, remove the addresses listed as reserved, and add the result one address at a time.

You can't do this for the fixed networks, but that use case doesn't make as much sense as the floating case, IMO.

Comment 7 arkady kanevsky 2014-08-06 13:40:04 UTC
While the bug is filed in the content of Fixed and Floating IP address for nova this bug is generic for all networks.
The specific example were we bumped into it is that network is specified as "/". This does not let us restrict some IP addresses that fall into that space, like one used for gateway. Another example is when single L2 network is split into ranges used for different purposes. Example of that is provisioning network used for both OSP installer and for Ceph installer. Thus, we need an interface to specify the range to use.

Comment 8 Brent Eagles 2014-08-06 13:42:56 UTC
There is some nova-network related work under way upstream that is making good progress:

blueprint: https://blueprints.launchpad.net/nova/+spec/better-support-for-multiple-networks
patches: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/better-support-for-multiple-networks,n,z

While the approach is different than what is proposed, a similar end result can be achieved by providing a start and end of the address range for use by VMs.

Comment 9 Mike Burns 2014-08-06 14:01:23 UTC
Jarda/Scott, we need to evaluate and do so UI design work for this.

Comment 10 Perry Myers 2014-08-06 20:03:45 UTC
This bug affects Staypuft, Puppet and there is Nova blueprint in play.  Therefore, we need to clone this bug to both openstack-puppet-modules and openstack-nova to track those dependencies.

In the short term, users can use the appropriate Nova CLI/API commands post installation to remove specific ip addresses from the ips that would be handed out.

Comment 12 Mike Orazi 2014-11-25 19:48:59 UTC
This functionality is no longer required as part of the target deployment architecture.

Comment 13 Julie 2015-01-20 01:35:38 UTC
hi Mike,
    In the doc text field, it says"TBD: Need to add an example command here to show how to remove an ip address". Would you be able to provide an example command?

Kind regards,
Julie

Comment 14 Mike Burns 2015-01-20 14:06:26 UTC
(In reply to Julie from comment #13)
> hi Mike,
>     In the doc text field, it says"TBD: Need to add an example command here
> to show how to remove an ip address". Would you be able to provide an
> example command?
> 
> Kind regards,
> Julie

Russell/Brent, is this something you can provide? or point us to the right person?

Comment 15 Russell Bryant 2015-01-20 15:40:15 UTC
(In reply to Mike Burns from comment #14)
> (In reply to Julie from comment #13)
> > hi Mike,
> >     In the doc text field, it says"TBD: Need to add an example command here
> > to show how to remove an ip address". Would you be able to provide an
> > example command?
> > 
> > Kind regards,
> > Julie
> 
> Russell/Brent, is this something you can provide? or point us to the right
> person?

This bug was closed as wontfix.  Is the documentation still relevant?  I'm also not sure this was actually implemented.

Comment 16 Julie 2015-01-22 01:51:13 UTC
Hi Perry, 
    If this bug doesn't require doc text anymore, can you set the requires_doc_text to - please?

Cheers,
Julie


Note You need to log in before you can comment on or make changes to this bug.