Bug 1126684 - FormatCreateError: ('device does not exist', '/dev/sda2')
Summary: FormatCreateError: ('device does not exist', '/dev/sda2')
Keywords:
Status: CLOSED DUPLICATE of bug 1120406
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c67baa6f44671736fa85b5507c8...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 05:25 UTC by A.J. Werkman
Modified: 2014-08-08 15:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 15:56:29 UTC


Attachments (Terms of Use)
File: anaconda-tb (842.40 KB, text/plain)
2014-08-05 05:26 UTC, A.J. Werkman
no flags Details
File: anaconda.log (40.86 KB, text/plain)
2014-08-05 05:26 UTC, A.J. Werkman
no flags Details
File: environ (459 bytes, text/plain)
2014-08-05 05:26 UTC, A.J. Werkman
no flags Details
File: lsblk_output (2.71 KB, text/plain)
2014-08-05 05:26 UTC, A.J. Werkman
no flags Details
File: nmcli_dev_list (1.15 KB, text/plain)
2014-08-05 05:26 UTC, A.J. Werkman
no flags Details
File: os_info (377 bytes, text/plain)
2014-08-05 05:26 UTC, A.J. Werkman
no flags Details
File: program.log (52.99 KB, text/plain)
2014-08-05 05:26 UTC, A.J. Werkman
no flags Details
File: storage.log (339.88 KB, text/plain)
2014-08-05 05:26 UTC, A.J. Werkman
no flags Details
File: syslog (159.74 KB, text/plain)
2014-08-05 05:26 UTC, A.J. Werkman
no flags Details
File: ifcfg.log (2.09 KB, text/plain)
2014-08-05 05:26 UTC, A.J. Werkman
no flags Details
File: packaging.log (195.75 KB, text/plain)
2014-08-05 05:26 UTC, A.J. Werkman
no flags Details

Description A.J. Werkman 2014-08-05 05:25:59 UTC
Version-Release number of selected component:
anaconda-21.48-1

The following was filed automatically by anaconda:
anaconda 21.48-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 388, in doFormat
    raise FormatCreateError("device does not exist", self.device)
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 820, in create
    return self.doFormat(options=kwargs.get('options'))
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 554, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 354, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 356, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 216, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 178, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
FormatCreateError: ('device does not exist', '/dev/sda2')

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:UUID=f17b5b5e-ce1f-4cc0-9e92-b9ad7f338b4c
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.16.0-0.rc6.git1.1.fc21.x86_64
product:        Server
release:        Cannot get release name.
type:           anaconda
version:        21-Alpha-T2

Potential duplicate: bug 1121398

Comment 1 A.J. Werkman 2014-08-05 05:26:04 UTC
Created attachment 924080 [details]
File: anaconda-tb

Comment 2 A.J. Werkman 2014-08-05 05:26:06 UTC
Created attachment 924081 [details]
File: anaconda.log

Comment 3 A.J. Werkman 2014-08-05 05:26:07 UTC
Created attachment 924082 [details]
File: environ

Comment 4 A.J. Werkman 2014-08-05 05:26:08 UTC
Created attachment 924083 [details]
File: lsblk_output

Comment 5 A.J. Werkman 2014-08-05 05:26:09 UTC
Created attachment 924084 [details]
File: nmcli_dev_list

Comment 6 A.J. Werkman 2014-08-05 05:26:10 UTC
Created attachment 924085 [details]
File: os_info

Comment 7 A.J. Werkman 2014-08-05 05:26:12 UTC
Created attachment 924086 [details]
File: program.log

Comment 8 A.J. Werkman 2014-08-05 05:26:14 UTC
Created attachment 924087 [details]
File: storage.log

Comment 9 A.J. Werkman 2014-08-05 05:26:16 UTC
Created attachment 924088 [details]
File: syslog

Comment 10 A.J. Werkman 2014-08-05 05:26:18 UTC
Created attachment 924089 [details]
File: ifcfg.log

Comment 11 A.J. Werkman 2014-08-05 05:26:20 UTC
Created attachment 924090 [details]
File: packaging.log

Comment 12 Orion Poplawski 2014-08-08 15:56:29 UTC

*** This bug has been marked as a duplicate of bug 1120406 ***


Note You need to log in before you can comment on or make changes to this bug.