Bug 1120720 - [AAA] AAA Rewrite minor issues and fixups
Summary: [AAA] AAA Rewrite minor issues and fixups
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Alon Bar-Lev
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
: 1120609 1122863 (view as bug list)
Depends On:
Blocks: oVirt-AAA-rewrite
TreeView+ depends on / blocked
 
Reported: 2014-07-17 14:45 UTC by Alon Bar-Lev
Modified: 2016-02-10 19:31 UTC (History)
8 users (show)

Fixed In Version: ovirt-3.5.0-beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:30:36 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30237 ovirt-engine-3.5 MERGED aaa: remove proprietary logger Never
oVirt gerrit 30248 ovirt-engine-3.5 MERGED extapi: use collection instead of list Never
oVirt gerrit 30460 ovirt-engine-3.5 MERGED aaa: Using collection instead of list Never
oVirt gerrit 30461 ovirt-engine-3.5 MERGED aaa: Optimizing fetchPrincipalIdsRecursively Never
oVirt gerrit 30487 ovirt-engine-3.5 MERGED aaa: more fixes to sync and usages Never
oVirt gerrit 30572 ovirt-engine-3.5 MERGED bll: move aaa related logics into aaa subpackage Never
oVirt gerrit 30580 ovirt-engine-3.5 MERGED common: move aaa entities to aaa subpackage Never
oVirt gerrit 30611 ovirt-engine-3.5 MERGED aaa: move builtin utils into builtins Never
oVirt gerrit 30612 ovirt-engine-3.5 MERGED aaa: more sync fixes Never
oVirt gerrit 30621 ovirt-engine-3.5 MERGED restapi: move aaa artifact to own subpackage Never
oVirt gerrit 30624 ovirt-engine-3.5 MERGED aaa: fixing more context issues Never
oVirt gerrit 30746 ovirt-engine-3.5 MERGED aaa: Fix "directory group" sub tab Never
oVirt gerrit 30941 ovirt-engine-3.5 MERGED aaa: populate display group earlier at login Never
oVirt gerrit 30942 ovirt-engine-3.5 MERGED aaa: sync: cleanup: remove unused variable Never
oVirt gerrit 30943 ovirt-engine-3.5 MERGED aaa: sync: copy isAdmin from existing user Never
oVirt gerrit 31053 ovirt-engine-3.5 MERGED core: Adding context ctor to UpgradeOvirtNodeInternalCommand Never
oVirt gerrit 31072 ovirt-engine-3.5 MERGED aaa: ldap-core is not required outside of builtin extensions Never
oVirt gerrit 31073 ovirt-engine-3.5 MERGED aaa: builtin: remove redundant dependency Never
oVirt gerrit 31094 ovirt-engine-3.5 MERGED packaging: spec: sort spring deps Never
oVirt gerrit 31327 ovirt-engine-3.5 MERGED extmgr: use trace level for trace extension interaction Never
oVirt gerrit 31550 ovirt-engine-3.5 MERGED aaa: Reorder "namespace" and "authz" columns Never
oVirt gerrit 31551 ovirt-engine-3.5 MERGED aaa: Remove "active" from groups Never
oVirt gerrit 31743 ovirt-engine-3.5 MERGED aaa: Coverity fixing Never
oVirt gerrit 31744 ovirt-engine-3.5 MERGED aaa: Removing unused method from DbUser Never
oVirt gerrit 31745 ovirt-engine-3.5 MERGED aaa: Fix redundant synch print message for admin user Never
oVirt gerrit 31746 ovirt-engine-3.5 MERGED aaa: Adding namespace sorting Never
oVirt gerrit 31781 ovirt-engine-3.5 MERGED aaa: Rename "domain" in ui Never
oVirt gerrit 31877 ovirt-engine-3.5 MERGED aaa: more coverity fixes Never
oVirt gerrit 31928 ovirt-engine-3.5 MERGED aaa: Removing groups from users main tab Never
oVirt gerrit 32008 ovirt-engine-3.5 MERGED aaa: Associate users only with managed groups by oVirt Never
oVirt gerrit 32024 ovirt-engine-3.5 MERGED extmgr: Add logging for extension load/initialize Never
oVirt gerrit 32150 ovirt-engine-3.5 MERGED aaa: search by user and groups name when added via rest-api Never
oVirt gerrit 32224 ovirt-engine-3.5 MERGED extapi: ExtMap.get() allow null default value Never
oVirt gerrit 32340 ovirt-engine-3.5 MERGED aaa: Add support to principal field in ui,rest-api, and built-in extension Never
oVirt gerrit 32441 ovirt-engine-3.5 MERGED extapi: aaa: support group resolution control for fetch principal Never
oVirt gerrit 32474 ovirt-engine-3.5 MERGED aaa: disabling "go" search button when there are no namespaces Never
oVirt gerrit 32475 ovirt-engine-3.5 MERGED aaa: Fix principal presentation at UI Never
oVirt gerrit 32705 ovirt-engine-3.5 MERGED aaa: Fix search to search properly for users by groups Never
oVirt gerrit 32779 ovirt-engine-3.5 MERGED aaa: Fix group name issues for legacy provider Never
oVirt gerrit 32801 ovirt-engine-3.5 MERGED aaa: do not display non password authn profiles within login Never
oVirt gerrit 32804 ovirt-engine-3.5 MERGED aaa: use Authn.Capabilities.AUTHENTICATE_CREDENTIALS correctly Never
oVirt gerrit 32812 ovirt-engine-3.5 MERGED aaa: Fix group population for legacy provider Never
oVirt gerrit 32917 ovirt-engine-3.5 MERGED aaa: cleanup: remove unused function Never
oVirt gerrit 32918 ovirt-engine-3.5 MERGED aaa: filters: cleanup: use profile object directly Never
oVirt gerrit 32919 ovirt-engine-3.5 MERGED extapi: move authn config keys into api Never
oVirt gerrit 32920 ovirt-engine-3.5 MERGED aaa: add authn negotiation priority Never
oVirt gerrit 32921 ovirt-engine-3.5 MERGED aaa: make AuthenticationProfileRepository observable Never
oVirt gerrit 32940 ovirt-engine-3.5 MERGED restapi: aaa: fix coverity issue, default encoding Never
oVirt gerrit 33409 ovirt-engine-3.5 MERGED extmgr: add nested exception message into new exception Never
oVirt gerrit 34104 ovirt-engine-3.5 MERGED aaa: remove group should not depend on existence of provider Never
oVirt gerrit 34105 ovirt-engine-3.5 MERGED aaa: Fix UserGroups list model Never
oVirt gerrit 34106 ovirt-engine-3.5 MERGED aaa: Admin user is not properly synchronized Never
oVirt gerrit 34107 ovirt-engine-3.5 MERGED aaa: remove duplicate groups from entities Never
oVirt gerrit 34135 ovirt-engine-3.5 MERGED builtin-extensions: remove EngineEncryptionUtils usage Never
oVirt gerrit 34136 ovirt-engine-3.5 MERGED aaa: Suppress compiler warnings for unchecked cast Never

Description Alon Bar-Lev 2014-07-17 14:45:15 UTC
A generic bug for leftovers of aaa rewrite for 3.5, to make gerrit hooks happy.

Comment 1 Yair Zaslavsky 2014-07-22 04:36:24 UTC
*** Bug 1120609 has been marked as a duplicate of this bug. ***

Comment 2 Piotr Kliczewski 2014-08-02 17:22:06 UTC
*** Bug 1122863 has been marked as a duplicate of this bug. ***

Comment 3 Sandro Bonazzola 2014-10-17 12:30:36 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.