Bug 1120947 - FormatCreateError: ('invalid device specification', '/dev/sda5')
Summary: FormatCreateError: ('invalid device specification', '/dev/sda5')
Keywords:
Status: CLOSED DUPLICATE of bug 1109244
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:eb281503135df89e9db5896df96...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 03:21 UTC by Chris Murphy
Modified: 2014-09-25 18:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-25 18:52:36 UTC


Attachments (Terms of Use)
File: anaconda-tb (597.70 KB, text/plain)
2014-07-18 03:21 UTC, Chris Murphy
no flags Details
File: anaconda.log (21.42 KB, text/plain)
2014-07-18 03:21 UTC, Chris Murphy
no flags Details
File: environ (458 bytes, text/plain)
2014-07-18 03:21 UTC, Chris Murphy
no flags Details
File: lsblk_output (1.72 KB, text/plain)
2014-07-18 03:21 UTC, Chris Murphy
no flags Details
File: nmcli_dev_list (1.08 KB, text/plain)
2014-07-18 03:21 UTC, Chris Murphy
no flags Details
File: os_info (377 bytes, text/plain)
2014-07-18 03:21 UTC, Chris Murphy
no flags Details
File: program.log (62.91 KB, text/plain)
2014-07-18 03:21 UTC, Chris Murphy
no flags Details
File: storage.log (156.68 KB, text/plain)
2014-07-18 03:21 UTC, Chris Murphy
no flags Details
File: syslog (65.85 KB, text/plain)
2014-07-18 03:21 UTC, Chris Murphy
no flags Details
File: ifcfg.log (1.90 KB, text/plain)
2014-07-18 03:21 UTC, Chris Murphy
no flags Details
File: packaging.log (235.50 KB, text/plain)
2014-07-18 03:21 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2014-07-18 03:21:06 UTC
Version-Release number of selected component:
anaconda-21.48-1

The following was filed automatically by anaconda:
anaconda 21.48-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/__init__.py", line 370, in create
    raise FormatCreateError("invalid device specification", self.device)
  File "/usr/lib/python2.7/site-packages/blivet/formats/lvmpv.py", line 121, in create
    DeviceFormat.create(self, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 554, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 354, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 356, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 216, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 178, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
FormatCreateError: ('invalid device specification', '/dev/sda5')

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-21-x86-64 enforcing=0 nomodeset elevator=deadline
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.16.0-0.rc5.git1.1.fc21.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        21

Potential duplicate: bug 1109565

Comment 1 Chris Murphy 2014-07-18 03:21:08 UTC
Created attachment 918934 [details]
File: anaconda-tb

Comment 2 Chris Murphy 2014-07-18 03:21:09 UTC
Created attachment 918935 [details]
File: anaconda.log

Comment 3 Chris Murphy 2014-07-18 03:21:10 UTC
Created attachment 918936 [details]
File: environ

Comment 4 Chris Murphy 2014-07-18 03:21:11 UTC
Created attachment 918937 [details]
File: lsblk_output

Comment 5 Chris Murphy 2014-07-18 03:21:11 UTC
Created attachment 918938 [details]
File: nmcli_dev_list

Comment 6 Chris Murphy 2014-07-18 03:21:12 UTC
Created attachment 918939 [details]
File: os_info

Comment 7 Chris Murphy 2014-07-18 03:21:13 UTC
Created attachment 918940 [details]
File: program.log

Comment 8 Chris Murphy 2014-07-18 03:21:14 UTC
Created attachment 918941 [details]
File: storage.log

Comment 9 Chris Murphy 2014-07-18 03:21:15 UTC
Created attachment 918942 [details]
File: syslog

Comment 10 Chris Murphy 2014-07-18 03:21:15 UTC
Created attachment 918943 [details]
File: ifcfg.log

Comment 11 Chris Murphy 2014-07-18 03:21:16 UTC
Created attachment 918944 [details]
File: packaging.log

Comment 12 Chris Murphy 2014-07-18 03:24:17 UTC
Could be a duplicate of bug 1120899. I pretty much always hit this in a virtualbox VM, UEFI or BIOS, when doing installs to Windows 7 or 8 volumes that require resizing. The resize seems to work, the problem happens when creating new volumes.

Comment 13 Chris Murphy 2014-07-18 04:23:52 UTC
This particular bug's crash results in data loss bug 1120964.

Comment 14 David Lehman 2014-07-18 12:56:02 UTC
Looks about the same as bug 1120899, bug 1109244, bug 1120406. Have you tried the updates image from https://bugzilla.redhat.com/show_bug.cgi?id=1109244#c21 yet? please stop filing new bugs until you do.

Comment 15 Chris Murphy 2014-07-18 14:25:04 UTC
Yes and I run into Bug 1120902.

Comment 16 Chris Murphy 2014-07-18 15:31:16 UTC
Succeeds 1 out of 1 attempts with 1109244.1.img

Comment 17 Rui Gouveia 2014-09-24 09:18:50 UTC
Another user experienced a similar problem:

Env:
KVM virtual machine on Fedora 20 using virt-manager.

Steps:
1. Start install process.
2. Accept the disk defaults.
3. Click 'Begin installation'.
4. Click to set root password.

Added notes:
I went forward and back a few times in the disk options.
I clicked to set the root password while the partitions where being created.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Workstation-x86_64-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.16.1-301.fc21.x86_64
other involved packages: python-blivet-0.62-1.fc21.noarch, python-libs-2.7.8-4.1.fc21.x86_64
package:        anaconda-core-21.48.6-1.fc21.x86_64
packaging.log:  
product:        Fedora
reason:         FormatCreateError: ('invalid device specification', '/dev/vda2')
release:        Fedora release 21 (Twenty One)
version:        21

Comment 18 David Lehman 2014-09-25 18:52:36 UTC

*** This bug has been marked as a duplicate of bug 1109244 ***


Note You need to log in before you can comment on or make changes to this bug.