Bug 1121643 - vdsm does not report stats for vlan devices due to a sloppy backport
Summary: vdsm does not report stats for vlan devices due to a sloppy backport
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.3
Assignee: Dan Kenigsberg
QA Contact: Gil Klein
URL:
Whiteboard: network
Depends On:
Blocks: 1117634 1123858
TreeView+ depends on / blocked
 
Reported: 2014-07-21 13:00 UTC by Maurice James
Modified: 2014-08-11 08:37 UTC (History)
9 users (show)

Fixed In Version: vdsm-4.14.11.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 08:37:50 UTC
oVirt Team: ---


Attachments (Terms of Use)
Supervdsm log (1.49 MB, application/zip)
2014-07-21 13:00 UTC, Maurice James
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30547 ovirt-3.4 MERGED net sampling: drop reference to a non-existing function Never

Description Maurice James 2014-07-21 13:00:29 UTC
Created attachment 919630 [details]
Supervdsm log

Description of problem: Engine reporting that the host interfaces are down but the really are not


Version-Release number of selected component (if applicable):
3.4.3

How reproducible:
100%

Steps to Reproduce:
1.Upgrade to ovirt 3.4.3
2.Host network status immediately drops


Actual results:
Host network status unknown, which causes the entire data center to go offline

Expected results:
All hosts and network show as online

Additional info:

Comment 1 Dan Kenigsberg 2014-07-21 17:10:47 UTC
It's a worrying dup of https://bugzilla.redhat.com/show_bug.cgi?id=1121145#c7

Thread-12::ERROR::2014-07-21 07:40:07,373::sampling::438::vds::(run) Error while sampling stats
Traceback (most recent call last):
  File "/usr/share/vdsm/sampling.py", line 420, in run
    sample = self.sample()
  File "/usr/share/vdsm/sampling.py", line 410, in sample
    hs = HostSample(self._pid)
  File "/usr/share/vdsm/sampling.py", line 186, in __init__
    (link.name, InterfaceSample(link)) for link in getLinks())
  File "/usr/share/vdsm/sampling.py", line 186, in <genexpr>
    (link.name, InterfaceSample(link)) for link in getLinks())
  File "/usr/share/vdsm/sampling.py", line 109, in __init__
    self.speed = _getLinkSpeed(link)
  File "/usr/share/vdsm/sampling.py", line 547, in _getLinkSpeed
    speed = netinfo.vlanSpeed(dev.name)
AttributeError: 'module' object has no attribute 'vlanSpeed'

Comment 2 Dan Kenigsberg 2014-07-21 17:26:33 UTC
*** Bug 1121145 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.