Bug 1122185 - It's not clear how to do a partial search
Summary: It's not clear how to do a partial search
Keywords:
Status: CLOSED DUPLICATE of bug 1259374
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 17:42 UTC by Partha Aji
Modified: 2016-04-22 15:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-08 20:35:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6728 None None None 2016-04-22 15:04:39 UTC

Description Partha Aji 2014-07-22 17:42:42 UTC
Users are trying to find products by searching with "R" instead of "R*" and looking at the UI, there's no sort of help tip or any indication of what the search syntax should be.

Comment 1 Partha Aji 2014-07-22 17:42:43 UTC
Created from redmine issue http://projects.theforeman.org/issues/6728

Comment 2 David Davis 2014-07-22 17:43:59 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=1115316 for more information

Comment 3 David Davis 2014-07-22 17:45:08 UTC
Another option might be to adopt Foreman's search syntax.

Comment 5 Brad Buckingham 2014-07-24 13:38:01 UTC
Ideally, we need to support a unified search syntax across the UI.  In the near-term, we might want to consider supporting a helptip on those areas that require lucene syntax.  Another alternative is something in the user documentation or release notes; however, having it on the UI would minimize the need to 'locate' the information.

Comment 6 David Davis 2014-07-24 13:39:26 UTC
Brad, I'll open a separate bug for addressing a unified search syntax across the UI.

Comment 7 David Davis 2014-07-24 13:44:21 UTC
Opened https://bugzilla.redhat.com/show_bug.cgi?id=1122972

Comment 8 Jan Hutař 2014-07-25 07:10:47 UTC
+1 for "support a unified search syntax across the UI" - from customer view this is one product and should have consistent search experience all over the webUI.

Comment 9 Bryan Kearney 2015-08-25 17:59:19 UTC
Upstream bug component is WebUI

Comment 10 Bryan Kearney 2015-10-08 20:35:31 UTC

*** This bug has been marked as a duplicate of bug 1259374 ***


Note You need to log in before you can comment on or make changes to this bug.