Bug 1122540 - [RFE] Need ability to specify NIC bonding for node network setup
Summary: [RFE] Need ability to specify NIC bonding for node network setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: z2
: Installer
Assignee: Marek Hulan
QA Contact: Alexander Chuzhoy
URL: https://trello.com/c/loHeFAXW
Whiteboard: MVP
: 1119819 (view as bug list)
Depends On:
Blocks: 1108193 1119874 1122553 1127449
TreeView+ depends on / blocked
 
Reported: 2014-07-23 13:10 UTC by arkady kanevsky
Modified: 2016-04-26 20:21 UTC (History)
14 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.2-1.el6ost
Doc Type: Enhancement
Doc Text:
Users can now configure network bonding of target hosts through the Red Hat Enterprise Linux OpenStack Platform Installer user interface.
Clone Of: 1122535
Environment:
Last Closed: 2014-11-04 17:01:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description arkady kanevsky 2014-07-23 13:10:34 UTC
+++ This bug was initially created as a clone of Bug #1122535 +++

Description of problem:
OSP deployments requires setting of NIC bonding. Bonding type and which NICs to bond is dependent on bundle and node type.

Requires consistent enumeration of NICs, including across reboots.

In a future need to be extended to bridging also.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from arkady kanevsky on 2014-07-23 09:02:17 EDT ---

See joint Dell/RedHat RA for examples of bonding requirements

Comment 2 Mike Burns 2014-07-25 13:29:39 UTC
The RHEL-OSP installer currently runs only on RHEL 6.  Changes made on RHEL 6 will apply to RHEL-OSP deployments on both RHEL 6 and RHEL 7.  Closing this bug as a duplicate since we only need to track it in 1 place.

*** This bug has been marked as a duplicate of bug 1122535 ***

Comment 4 Mike Burns 2014-10-07 16:05:09 UTC
*** Bug 1119819 has been marked as a duplicate of this bug. ***

Comment 6 Alexander Chuzhoy 2014-10-14 17:00:36 UTC
Verified:
rhel-osp-installer-0.4.2-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-23.el6ost.noarch
openstack-foreman-installer-2.0.29-1.el6ost.noarch



There's an option to configure bonding now under "Configure Networks" menu.

Configured bonding and verified it was created properly on the node.

Comment 12 errata-xmlrpc 2014-11-04 17:01:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.