Bug 1122535 - [RFE] Need ability to specify NIC bonding for node network setup
Summary: [RFE] Need ability to specify NIC bonding for node network setup
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: Foreman (RHEL 6)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z1
: Installer
Assignee: Marek Hulan
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1119353 1119874 1122550 1122553 1122556 1127449
TreeView+ depends on / blocked
 
Reported: 2014-07-23 12:57 UTC by arkady kanevsky
Modified: 2016-04-27 01:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1122540 (view as bug list)
Environment:
Last Closed: 2014-08-06 21:03:35 UTC


Attachments (Terms of Use)

Description arkady kanevsky 2014-07-23 12:57:35 UTC
Description of problem:
OSP deployments requires setting of NIC bonding. Bonding type and which NICs to bond is dependent on bundle and node type.

Requires consistent enumeration of NICs, including across reboots.

In a future need to be extended to bridging also.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 arkady kanevsky 2014-07-23 13:02:17 UTC
See joint Dell/RedHat RA for examples of bonding requirements

Comment 3 Mike Burns 2014-07-25 13:29:39 UTC
*** Bug 1122540 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.