Bug 1122553 - [RFE] Need an ability to specify vLAN (tagged) on top of individual NICs per network per node type
Summary: [RFE] Need an ability to specify vLAN (tagged) on top of individual NICs per ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: All
OS: Linux
urgent
high
Target Milestone: z1
: Installer
Assignee: Marek Hulan
QA Contact: Ofer Blaut
URL: https://trello.com/c/QEbYmZJi
Whiteboard: MVP
Depends On: 1122535 1122540
Blocks: 1108193 1119353 1122583 1127449
TreeView+ depends on / blocked
 
Reported: 2014-07-23 13:36 UTC by arkady kanevsky
Modified: 2016-04-27 05:40 UTC (History)
11 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.3.4-2.el6ost
Doc Type: Enhancement
Doc Text:
Clone Of: 1122550
: 1122556 1127449 (view as bug list)
Environment:
Last Closed: 2014-10-01 13:25:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description arkady kanevsky 2014-07-23 13:36:09 UTC
+++ This bug was initially created as a clone of Bug #1122550 +++

Description of problem:
For OSP deployment Customers require ability to define infrastructure network(s) per node type on top of individual NICs, bonded network, or bridged networks.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from arkady kanevsky on 2014-07-23 09:35:11 EDT ---

See joint Dell/RedHat RA for examples of network requirements

Comment 2 Mike Burns 2014-07-25 13:30:26 UTC
The RHEL-OSP installer currently runs only on RHEL 6.  Changes made on RHEL 6 will apply to RHEL-OSP deployments on both RHEL 6 and RHEL 7.  Closing this bug as a duplicate since we only need to track it in 1 place.

*** This bug has been marked as a duplicate of bug 1122550 ***

Comment 4 Perry Myers 2014-08-06 21:12:14 UTC
This bug is specific to tracking the network assignment enhancements coming to Staypuft for A1 async release.  The ability to do this on top of bonded network interfaces will be tracked in a subsequent delivery/cloned bug.

Using untagged VLAN interfaces should be transparent to Staypuft and should just be a validation effort

Comment 8 Marek Hulan 2014-09-30 07:35:21 UTC
If you want to define a VLAN interface you don't change existing physical device but you create a new one that is VLAN and is attached to physical device. Easier is to assign the VLAN subnet to physical device in staypuft wizard (which creates the VLAN interface for you) and then go to host form and edit it (override VLAN tag on VLAN device)

Comment 9 Ofer Blaut 2014-09-30 11:36:39 UTC
Tested using subent with VLAN and attached it to interface 
rhel-osp-installer-0.3.6-1.el6ost.noarch

Comment 11 errata-xmlrpc 2014-10-01 13:25:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.