Bug 1122741 - [RFE] OSP deployer needs an ability to automatically extract keyring file from Ceph cluster (node) and populate controller and compute nodes
Summary: [RFE] OSP deployer needs an ability to automatically extract keyring file fro...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1122744 1122745
TreeView+ depends on / blocked
 
Reported: 2014-07-24 00:30 UTC by arkady kanevsky
Modified: 2016-04-27 00:22 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1122742 (view as bug list)
Environment:
Last Closed: 2014-08-06 21:27:24 UTC


Attachments (Terms of Use)

Description arkady kanevsky 2014-07-24 00:30:16 UTC
Description of problem:
Assumption: Ceph is deployed before OpenStack is deployed (or at least cinder/glance/nova are configured)
(Nova is needed for use of Ceph for ephemeral storage for live migration - lower priority)

OSP deployer need to extract keyring file of Ceph cluster (from any of its nodes) and install on all nodes where cinder and glance will be installed. (Nova is stretch goal for GA but will be required later to support live migration and/or ephemeral storage).

For a short term solution, it may be possible to achieve it with ICE writing keyring file in agreed to location on admin node where OSP Foreman/Staypuft are installed.

A separate bug will be filed for automatically update cinder/glance/nova nodes everytime Ceph keyring is modified, e.g. Ceph node failure, Ceph cluster node addition, removal, and or replacement.

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 arkady kanevsky 2014-07-24 00:33:39 UTC
This functionality is need for solution GA

Comment 3 Mike Burns 2014-07-25 13:36:10 UTC
*** Bug 1122742 has been marked as a duplicate of this bug. ***

Comment 4 Mike Burns 2014-07-25 13:36:58 UTC
From duplicate bug:

The ceph-deploy script (provided as part of the ICE Installer) can place a copy of the ceph.conf and keyring on any host it has SSH access to. As these file's locations are usually well defined, the cinder & glance config files can point to them (in their own respective config files) before they are even installed.

When the MONs are cohosted on the RHEL-OSP controllers, then when ceph-deploy installs the MON software, it will *also* install the ceph.conf and keyring too, so for this initial configuration, the step requested in this BZ is redudant. 

However, it is needed to push the config files to any other hosts such as compute hosts or any additional hosts that may be added to the system.


Note You need to log in before you can comment on or make changes to this bug.