Bug 1122745 - [RFE] OSP deployer needs an ability to automatically update any changes to keyring file from Ceph cluster (node) to controller and compute nodes
Summary: [RFE] OSP deployer needs an ability to automatically update any changes to ke...
Keywords:
Status: CLOSED DUPLICATE of bug 1122744
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On: 1122741
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 01:12 UTC by arkady kanevsky
Modified: 2014-09-08 05:44 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1122744
Environment:
Last Closed: 2014-07-25 13:37:59 UTC


Attachments (Terms of Use)

Description arkady kanevsky 2014-07-24 01:12:17 UTC
+++ This bug was initially created as a clone of Bug #1122744 +++

Description of problem:
OSP deployer need an ability to track changes of Ceph keyring and update all OSP nodes that use Ceph with all changes.

It Ceph ICE is already tracking these changes as part of calamari then OSP Foreman/Staypuft can track keyring state changes on admin nodes.

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from arkady kanevsky on 2014-07-23 21:08:49 EDT ---

While not required for GA solution it is MUST to be able to add/remove/replace nodes of Ceph cluster and for automatically handling faults in ceph cluster

Comment 2 Mike Burns 2014-07-25 13:37:59 UTC
The RHEL-OSP installer currently runs only on RHEL 6.  Changes made on RHEL 6 will apply to RHEL-OSP deployments on both RHEL 6 and RHEL 7.  Closing this bug as a duplicate since we only need to track it in 1 place.

*** This bug has been marked as a duplicate of bug 1122744 ***


Note You need to log in before you can comment on or make changes to this bug.