Bug 1122744 - [RFE] OSP deployer needs an ability to automatically update any changes to keyring file from Ceph cluster (node) to controller and compute nodes
Summary: [RFE] OSP deployer needs an ability to automatically update any changes to ke...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: Foreman (RHEL 6)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: Installer
Assignee: Crag Wolfe
QA Contact: Shai Revivo
URL: https://trello.com/c/ifPeoTde/125-cep...
Whiteboard:
: 1122745 (view as bug list)
Depends On: 1122741
Blocks: 1163445 1198799
TreeView+ depends on / blocked
 
Reported: 2014-07-24 01:05 UTC by arkady kanevsky
Modified: 2016-08-03 00:28 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1122745 (view as bug list)
Environment:
Last Closed: 2016-08-02 21:47:30 UTC


Attachments (Terms of Use)

Description arkady kanevsky 2014-07-24 01:05:41 UTC
Description of problem:
OSP deployer need an ability to track changes of Ceph keyring and update all OSP nodes that use Ceph with all changes.

It Ceph ICE is already tracking these changes as part of calamari then OSP Foreman/Staypuft can track keyring state changes on admin nodes.

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 arkady kanevsky 2014-07-24 01:08:49 UTC
While not required for GA solution it is MUST to be able to add/remove/replace nodes of Ceph cluster and for automatically handling faults in ceph cluster

Comment 3 Mike Burns 2014-07-25 13:37:59 UTC
*** Bug 1122745 has been marked as a duplicate of this bug. ***

Comment 8 Karl Hastings 2016-08-02 21:14:22 UTC
It's been over a year since a substantive comment has been made in this bugzilla.  Is this still an active bug, or is it detritus that can be swept away?

Comment 9 arkady kanevsky 2016-08-02 21:17:54 UTC
Yes.
We moved to OSPd, so foreman requests are OBE.

Comment 10 Karl Hastings 2016-08-02 21:47:30 UTC
Closing.  If anyone disagrees with this feel free to reopen.


Note You need to log in before you can comment on or make changes to this bug.