Bug 1124449 - Fields under "Start Running On" in the "Edit Virtual Machine" window should be greyed out when the VM is up
Summary: Fields under "Start Running On" in the "Edit Virtual Machine" window should b...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
: 3.5.1
Assignee: Eldan Shachar
QA Contact: Ilanit Stein
URL:
Whiteboard: virt
: 1144810 1168638 1176799 (view as bug list)
Depends On:
Blocks: 1193058 1196662 1197441
TreeView+ depends on / blocked
 
Reported: 2014-07-29 14:04 UTC by Idan Shaby
Modified: 2016-02-10 19:48 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.5.1_rc1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 12:29:24 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32899 master MERGED core: Add migration options to OVF Never
oVirt gerrit 36757 ovirt-engine-3.5 MERGED core: Add migration options to OVF Never

Description Idan Shaby 2014-07-29 14:04:17 UTC
Description of problem:
While the VM is running, in the "Edit Virtual Machine" window, under the "Host" tab, the info tooltip message says that you can't edit the "Start Running On" fields, but it is not greyed out.
Look at the "Steps to Reproduce" section for an example to a scenario that should not happen.

Version-Release number of selected component (if applicable):
Built from source with commit e71e719e0f8e90b30fb0f7c57ce7de4b07cb963d.

How reproducible:
100%

Steps to Reproduce:
1. Edit a running VM from the UI - navigate to the "Virtual Machines" tab, click on a specific VM and then on "Edit".
2. Navigate to the "Host" tab.
3. Change the current selection under the "Start Running On" section.
4. Click OK, watch the misleading message "Some of the changes will be applied after the NEXT RESTART." and click OK.
5. Whatever you do, your change is gone (you can repeat steps 1 and 2 before or after shutting down the VM and see that the change is not saved).

Actual results:
The change you have made is not saved.

Expected results:
The "Start Running On" fields should be greyed out, or a proper message should be shown.

Additional info:

Comment 1 Michal Skrivanek 2014-07-30 08:58:49 UTC

*** This bug has been marked as a duplicate of bug 1124432 ***

Comment 2 Omer Frenkel 2014-07-31 07:21:05 UTC
this bug is different from bug 1124432
appears that migration options are missing from the snapshots mechanism (and therefor from import/export as well)
and this is why this configuration is not applied.

Comment 3 Omer Frenkel 2014-09-22 06:40:17 UTC
*** Bug 1144810 has been marked as a duplicate of this bug. ***

Comment 4 Omer Frenkel 2014-11-30 07:05:14 UTC
*** Bug 1168638 has been marked as a duplicate of this bug. ***

Comment 5 Omer Frenkel 2014-12-01 11:12:39 UTC
*** Bug 1168638 has been marked as a duplicate of this bug. ***

Comment 6 Tomas Jelinek 2015-01-08 10:21:55 UTC
*** Bug 1176799 has been marked as a duplicate of this bug. ***

Comment 7 Tomas Jelinek 2015-01-08 10:26:35 UTC
@Michal - are we sure we do not want to backport this to 3.5? The 1176799 is another incarnation of this bug and I'd say we will face more incarnations...

Comment 8 Michal Skrivanek 2015-01-08 10:38:05 UTC
sure

Comment 9 Michal Skrivanek 2015-01-08 10:39:57 UTC
please backport to 3.5 branch

Comment 10 Sandro Bonazzola 2015-01-15 14:15:25 UTC
This is an automated message: 
This bug should be fixed in oVirt 3.5.1 RC1, moving to QA

Comment 11 Sandro Bonazzola 2015-01-21 16:06:12 UTC
oVirt 3.5.1 has been released. If problems still persist, please make note of it in this bug report.

Comment 12 Eyal Edri 2015-02-26 12:32:53 UTC
this ovirt bug was fixed during 3.5.1 cycle and is included in the build, and therefore should be verified.

Comment 13 Ilanit Stein 2015-03-18 07:42:11 UTC
Verified on rhevm version vt14 (rhevm-3.5.1-0.1)


Note You need to log in before you can comment on or make changes to this bug.