Bug 1125168 - ec-method.c fails to compile in function 'ec_method_encode' due to unknown register name 'xmm7'
Summary: ec-method.c fails to compile in function 'ec_method_encode' due to unknown re...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 08:43 UTC by Niels de Vos
Modified: 2015-05-14 17:42 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1125277 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:53 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
build.log from http://copr-be.cloud.fedoraproject.org/results/devos/glusterfs/fedora-rawhide-i386/glusterfs-3.7dev-0.44.git60f2e23.autobuild/build.log (51.69 KB, text/plain)
2014-07-31 08:43 UTC, Niels de Vos
no flags Details

Description Niels de Vos 2014-07-31 08:43:47 UTC
Created attachment 922855 [details]
build.log from http://copr-be.cloud.fedoraproject.org/results/devos/glusterfs/fedora-rawhide-i386/glusterfs-3.7dev-0.44.git60f2e23.autobuild/build.log

Description of problem:
Compiling current glusterfs/master fails on Fedora Rawhide i386.

Version-Release number of selected component (if applicable):
- Fedore Rawhide (i386)
- glusterfs/master

How reproducible:
100%

Steps to Reproduce:
1. download a current SRPM from 
2. execute: mock -r fedora-rawhide-i386 $SRPM

Actual results:
Build fails.

Expected results:
Build succeeds.

Additional info:
ec-gf.c seems to have been compiled successfully and it also references XMM registers...

Comment 1 Anand Avati 2014-07-31 10:02:25 UTC
REVIEW: http://review.gluster.org/8395 (ec: Add -msse option to avoid fedora/rawhide compilation errors) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 2 Anand Avati 2014-07-31 10:15:50 UTC
REVIEW: http://review.gluster.org/8395 (ec: Add -msse option to avoid fedora/rawhide compilation errors) posted (#2) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 3 Xavi Hernandez 2014-07-31 10:24:23 UTC
Patch http://review.gluster.org/8395/ solves the compilation problem until the real solution (Bug #1125166) is finished.

Comment 4 Anand Avati 2014-07-31 10:31:13 UTC
REVIEW: http://review.gluster.org/8395 (ec: Add -msse2 option to avoid fedora/rawhide compilation errors) posted (#3) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 5 Anand Avati 2014-07-31 16:08:40 UTC
COMMIT: http://review.gluster.org/8395 committed in master by Anand Avati (avati@redhat.com) 
------
commit 9de6d8b555a5202cbf80753f41efa03032edb02b
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Thu Jul 31 11:51:12 2014 +0200

    ec: Add -msse2 option to avoid fedora/rawhide compilation errors
    
    This solves a compilation error on some compiler versions.
    To avoid compilation issues on non-Intel architectures, patch
    http://review.gluster.org/8366/ has already been merged. It
    disables ec on those architectures.
    
    These modifications are temporary patches until a proper
    solution for bug #1125166 is ready.
    
    Change-Id: I74d0b79e84601cc4f86ad08ce0f8102b99a79a68
    BUG: 1125168
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/8395
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 6 Niels de Vos 2015-05-14 17:26:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:37:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:42:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.