Bug 1125277 - ec-method.c fails to compile in function 'ec_method_encode' due to unknown register name 'xmm7'
Summary: ec-method.c fails to compile in function 'ec_method_encode' due to unknown re...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 13:25 UTC by Xavi Hernandez
Modified: 2014-11-11 08:37 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1125168
Environment:
Last Closed: 2014-11-11 08:37:13 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2014-07-31 13:25:50 UTC
+++ This bug was initially created as a clone of Bug #1125168 +++

Description of problem:
Compiling current glusterfs/master fails on Fedora Rawhide i386.

Version-Release number of selected component (if applicable):
- Fedore Rawhide (i386)
- glusterfs/master

How reproducible:
100%

Steps to Reproduce:
1. download a current SRPM from 
2. execute: mock -r fedora-rawhide-i386 $SRPM

Actual results:
Build fails.

Expected results:
Build succeeds.

Additional info:
ec-gf.c seems to have been compiled successfully and it also references XMM registers...

--- Additional comment from Anand Avati on 2014-07-31 12:02:25 CEST ---

REVIEW: http://review.gluster.org/8395 (ec: Add -msse option to avoid fedora/rawhide compilation errors) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

--- Additional comment from Anand Avati on 2014-07-31 12:15:50 CEST ---

REVIEW: http://review.gluster.org/8395 (ec: Add -msse option to avoid fedora/rawhide compilation errors) posted (#2) for review on master by Xavier Hernandez (xhernandez@datalab.es)

--- Additional comment from Xavier Hernandez on 2014-07-31 12:24:23 CEST ---

Patch http://review.gluster.org/8395/ solves the compilation problem until the real solution (Bug #1125166) is finished.

--- Additional comment from Anand Avati on 2014-07-31 12:31:13 CEST ---

REVIEW: http://review.gluster.org/8395 (ec: Add -msse2 option to avoid fedora/rawhide compilation errors) posted (#3) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 1 Anand Avati 2014-07-31 13:30:27 UTC
REVIEW: http://review.gluster.org/8396 (ec: Add -msse2 option to avoid fedora/rawhide compilation errors) posted (#1) for review on release-3.6 by Xavier Hernandez (xhernandez@datalab.es)

Comment 2 Anand Avati 2014-08-03 14:54:05 UTC
COMMIT: http://review.gluster.org/8396 committed in release-3.6 by Vijay Bellur (vbellur@redhat.com) 
------
commit 67dc88c6020bab33d5e4e7e41eafa4064386d016
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Thu Jul 31 11:51:12 2014 +0200

    ec: Add -msse2 option to avoid fedora/rawhide compilation errors
    
    This solves a compilation error on some compiler versions.
    To avoid compilation issues on non-Intel architectures, patch
    http://review.gluster.org/8381/ has already been merged. It
    disables ec on those architectures.
    
    These modifications are temporary patches until a proper
    solution for bug #1125166 is ready.
    
    This is a backport of http://review.gluster.org/8395/
    
    Change-Id: I74d0b79e84601cc4f86ad08ce0f8102b99a79a68
    BUG: 1125277
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/8396
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 3 Niels de Vos 2014-09-22 12:44:57 UTC
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/

Comment 4 Niels de Vos 2014-11-11 08:37:13 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users


Note You need to log in before you can comment on or make changes to this bug.