Bug 1132322 - ValueError: specified lv is not part of this vg
Summary: ValueError: specified lv is not part of this vg
Keywords:
Status: CLOSED DUPLICATE of bug 1128605
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:bf2368d8f5bcd4949e53a139952...
: 1075908 1114825 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-21 06:46 UTC by Ferdinand Galko
Modified: 2014-09-04 19:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-04 17:54:51 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (342.49 KB, text/plain)
2014-08-21 06:46 UTC, Ferdinand Galko
no flags Details
File: anaconda.log (20.66 KB, text/plain)
2014-08-21 06:46 UTC, Ferdinand Galko
no flags Details
File: environ (458 bytes, text/plain)
2014-08-21 06:46 UTC, Ferdinand Galko
no flags Details
File: lsblk_output (1.28 KB, text/plain)
2014-08-21 06:46 UTC, Ferdinand Galko
no flags Details
File: nmcli_dev_list (1.14 KB, text/plain)
2014-08-21 06:46 UTC, Ferdinand Galko
no flags Details
File: os_info (381 bytes, text/plain)
2014-08-21 06:46 UTC, Ferdinand Galko
no flags Details
File: program.log (17.50 KB, text/plain)
2014-08-21 06:46 UTC, Ferdinand Galko
no flags Details
File: storage.log (94.37 KB, text/plain)
2014-08-21 06:46 UTC, Ferdinand Galko
no flags Details
File: syslog (51.30 KB, text/plain)
2014-08-21 06:46 UTC, Ferdinand Galko
no flags Details
File: ifcfg.log (1.91 KB, text/plain)
2014-08-21 06:46 UTC, Ferdinand Galko
no flags Details
File: packaging.log (70.31 KB, text/plain)
2014-08-21 06:47 UTC, Ferdinand Galko
no flags Details

Description Ferdinand Galko 2014-08-21 06:46:38 UTC
Version-Release number of selected component:
anaconda-22.3-1

The following was filed automatically by anaconda:
anaconda 22.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2585, in _removeLogVol
    raise ValueError("specified lv is not part of this vg")
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 450, in _removeDevice
    dev.vg._removeLogVol(dev)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 521, in cancelAction
    self._removeDevice(action.device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1967, in hide
    self.cancelAction(action)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 353, in _hide_unusable_disks
    self._storage_playground.devicetree.hide(disk)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 121, in decorated
    return func(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 361, in _reset_storage
    self._hide_unusable_disks()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 376, in refresh
    self._reset_storage()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 351, in _on_spoke_clicked
    spoke.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 383, in spoke_done
    self._on_spoke_clicked(self._spokes[dest].selector, None, self._spokes[dest])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 50, in on_back_clicked
    self.main_window.current_action.spoke_done(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 869, in on_back_clicked
    NormalSpoke.on_back_clicked(self, button)
ValueError: specified lv is not part of this vg

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-rawhide-x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.17.0-0.rc1.git0.1.fc22.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide

Potential duplicate: bug 1121383

Comment 1 Ferdinand Galko 2014-08-21 06:46:43 UTC
Created attachment 929058 [details]
File: anaconda-tb

Comment 2 Ferdinand Galko 2014-08-21 06:46:44 UTC
Created attachment 929059 [details]
File: anaconda.log

Comment 3 Ferdinand Galko 2014-08-21 06:46:46 UTC
Created attachment 929060 [details]
File: environ

Comment 4 Ferdinand Galko 2014-08-21 06:46:47 UTC
Created attachment 929061 [details]
File: lsblk_output

Comment 5 Ferdinand Galko 2014-08-21 06:46:48 UTC
Created attachment 929062 [details]
File: nmcli_dev_list

Comment 6 Ferdinand Galko 2014-08-21 06:46:50 UTC
Created attachment 929063 [details]
File: os_info

Comment 7 Ferdinand Galko 2014-08-21 06:46:52 UTC
Created attachment 929064 [details]
File: program.log

Comment 8 Ferdinand Galko 2014-08-21 06:46:54 UTC
Created attachment 929065 [details]
File: storage.log

Comment 9 Ferdinand Galko 2014-08-21 06:46:56 UTC
Created attachment 929066 [details]
File: syslog

Comment 10 Ferdinand Galko 2014-08-21 06:46:58 UTC
Created attachment 929067 [details]
File: ifcfg.log

Comment 11 Ferdinand Galko 2014-08-21 06:47:00 UTC
Created attachment 929068 [details]
File: packaging.log

Comment 12 David Shea 2014-09-04 17:54:51 UTC

*** This bug has been marked as a duplicate of bug 1128605 ***

Comment 13 David Shea 2014-09-04 18:48:02 UTC
*** Bug 1114825 has been marked as a duplicate of this bug. ***

Comment 14 David Shea 2014-09-04 19:12:45 UTC
*** Bug 1075908 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.