Bug 1129578 - Confusion between environment and environemnt path
Summary: Confusion between environment and environemnt path
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs User Guide
Version: 6.0.3
Hardware: x86_64
OS: Linux
unspecified
low vote
Target Milestone: Unspecified
Assignee: Megan Lewis
QA Contact: Hayley Hudgeons
URL:
Whiteboard:
: 1120435 1127083 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 08:58 UTC by cmilsted
Modified: 2015-07-15 05:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Build Name: 14369, User Guide-6.0 Beta-1 Build Date: 18-07-2014 08:47:40 Topic ID: 9685-642854 [Latest]
Last Closed: 2015-07-15 05:20:32 UTC


Attachments (Terms of Use)
Screenshot (62.40 KB, image/png)
2014-08-13 08:58 UTC, cmilsted
no flags Details

Description cmilsted 2014-08-13 08:58:08 UTC
Created attachment 926326 [details]
Screenshot

Title: Adding a Lifecycle Environment to an Organization

Describe the issue: I am following the document 3.3.1 and 3.3.3. Firstly I followed 3.3.1 and, when I had set my context to be Organisation BSkyB with Location Isleworth, I then clicked:

Context -> Lifecycle Environment
Click + to create new environment Path

I setup three paths - see attached screenshot below.


I then follow steps in 3.3.3, Adding a Lifecycle Environment to an organisation.

I click Administer - > Organisations
The only environemnt I see is "Production".

There seems to be a missing piece here - as per picture 3.2. I need to create an Environment before I create an Environment Lifecycle? The above is confusing. I have dumped the hammer contents:

[root@cmilsted-rhel6 ~]# hammer environment list
---|-----------
ID | NAME      
---|-----------
1  | production
---|-----------

[root@cmilsted-rhel6 ~]# hammer lifecycle-environment list --organization BSkyB --library
---|------------------------------------|-----------------------------------
ID | NAME                               | PRIOR                             
---|------------------------------------|-----------------------------------
2  | Library                            |                                   
5  | PreProductionForSuperMegaTVService | TestForSuperMegaTVService         
8  | ProductionBogStandardTV            | DevelopmentBogStandardTV          
4  | TestForSuperMegaTVService          | DevelopmentForSuperMegaTVService  
7  | DevelopmentBogStandardTV           | Library                           
3  | DevelopmentForSuperMegaTVService   | Library                           
6  | ProdForSuperMegaTVService          | PreProductionForSuperMegaTVService
9  | DeveloperWorkstationWithAdobe      | Library                           
---|------------------------------------|-----------------------------------






Suggestions for improvement: Add section on envronments before paths.


Additional information: email me at cmilsted at redhat dot com

Comment 1 RHEL Product and Program Management 2014-08-13 09:03:00 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 David O'Brien 2014-08-14 08:03:18 UTC
*** Bug 1127083 has been marked as a duplicate of this bug. ***

Comment 5 Megan Lewis 2014-08-15 04:55:23 UTC
*** Bug 1120435 has been marked as a duplicate of this bug. ***

Comment 7 Athene Chan 2014-08-16 09:09:52 UTC
VERIFIED removal of sections


Note You need to log in before you can comment on or make changes to this bug.