Bug 1130174 - [RFE] turn Blank template into some kind of global defaults facility
Summary: [RFE] turn Blank template into some kind of global defaults facility
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Tomas Jelinek
QA Contact: Shira Maximov
URL:
Whiteboard:
: 1072045 (view as bug list)
Depends On: 1279524
Blocks: 1072384 1145002
TreeView+ depends on / blocked
 
Reported: 2014-08-14 13:42 UTC by Michal Skrivanek
Modified: 2016-03-03 08:37 UTC (History)
10 users (show)

Fixed In Version: ovirt-engine-3.6.0-0.0.master.20150412172306.git55ba764
Doc Type: Enhancement
Doc Text:
The "Blank" template is now editable and can be used as a global default facility to define some of the VM properties for VMs not using any custom template.
Clone Of:
Environment:
Last Closed: 2016-02-10 12:50:18 UTC
oVirt Team: Virt
rule-engine: ovirt-3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 37851 master MERGED core: enabled the editing of the RNG device for blank template Never
oVirt gerrit 37853 master MERGED core: load the vm init config also for the blank template Never
oVirt gerrit 37902 master MERGED core: enabled the custom properties to be set for blank template Never
oVirt gerrit 37903 master MERGED core: enable editing the watchdog for blank template Never
oVirt gerrit 37904 master MERGED core: made it possible to edit the blank template Never
oVirt gerrit 37905 master MERGED frontend: made the blank template editable Never
oVirt gerrit 38008 master MERGED restapi: made sure only the supported template entities are copied Never
oVirt gerrit 38817 master MERGED core: renamed the blank template to default Never

Description Michal Skrivanek 2014-08-14 13:42:48 UTC
Blank template is quite useless and a constant source of confusion.

We should make it editable so people can set a system-wide defaults. When it's renamed to "Defaults" it would also be a bit more clear why it can't be removed and is hard-wired into many flows.

And as a bonus, we can replace some of the VdcOptions-only global things with simple edit of the "Default" template

Comment 1 Michal Skrivanek 2014-08-15 13:25:10 UTC
*** Bug 1072045 has been marked as a duplicate of this bug. ***

Comment 2 Michal Skrivanek 2014-08-15 13:26:07 UTC
address sub-version of defaults too

Comment 3 Einav Cohen 2014-08-18 18:21:55 UTC
after consulting with Liz:
Short term, I think it is OK to rename the 'Blank' template to 'Defaults', allow users to edit it, etc. 
towards 4.0, I think that we should re-think whether it makes sense to treat that 'Blank'/'Default' entity as a Template (i.e. display it in the Templates main tab, etc.), or does it make more sense to allow a completely different way of controlling the defaults for creating a VM from scratch.

Comment 4 Tomas Jelinek 2015-04-14 06:14:52 UTC
Please note that the "38817: core: renamed the blank template to default" patch had to be rewerted because of backward compatibility - e.g. the implementation is that the blank template is editable but it is still named Blank. There is a possibility to rename it if the user decides to do so. 

The updated feature page: http://www.ovirt.org/Features/Blank_to_Defaults#Proposal

Comment 7 Shira Maximov 2015-07-08 14:04:34 UTC
Tomas, thanks for your comments. 
i added the a test case and specific about SPICE and VNC. 

please approve the test plan, 
thanks.

Comment 8 Tomas Jelinek 2015-07-13 07:35:53 UTC
yes, seems ok to me

Comment 9 Shira Maximov 2015-11-09 14:12:27 UTC
try to verify on :
Red Hat Enterprise Virtualization Manager Version: 3.6.0.3-0.1.el6


link to polarion test : 
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Compute/3_6_VIRT_Blank_template?query=NOT%20type:heading%20AND%20(NOT%20TEST_RECORDS:(%22RHEVM3/3_6_VIRT_Blank_template_2%22,@any))&tree_depth=0&tab=tree


failed on the following test :
check vnc+spice:
1. edit the blank template
2. got to Console tab 
3. in Graphics protocol choose VNC+SPICE
4. create 2 vms with this template -
   one with the 3.5 cluster and one with 3.6

The vm in 3.6 cluster will inheritance the VNC+SPICE and the vm in 3.5 should be inherit only SPICE but she also inheritance VNC+SPICE

Tomas, should i move this bug back to assigned?

Comment 10 Tomas Jelinek 2015-11-09 14:55:02 UTC
In cluster level 3.5 you should not be able to create a VM which has both SPICE and VNC (regardless of Blank template setting). So, if the combo box contains the SPICE+VNC than it is a separate bug (which blocks this one from verification but still a separate one...).


Note You need to log in before you can comment on or make changes to this bug.