Bug 1279524 - SPICE+VNC feature should not be available when creating a VM from Blank template on 3.5 cluster
SPICE+VNC feature should not be available when creating a VM from Blank templ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Tomas Jelinek
Shira Maximov
:
: 1299486 (view as bug list)
Depends On:
Blocks: 1130174
  Show dependency treegraph
 
Reported: 2015-11-09 11:11 EST by Shira Maximov
Modified: 2016-02-18 06:19 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:19:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48753 master MERGED core,frontend: allow spice+vnc only on 3.6+ cluster Never
oVirt gerrit 48855 ovirt-engine-3.6 MERGED core,frontend: allow spice+vnc only on 3.6+ cluster Never
oVirt gerrit 51353 master MERGED webadmin: blank template always has latest template 2016-01-07 14:18 EST
oVirt gerrit 51360 ovirt-engine-3.6 ABANDONED webadmin: spice and vnc not available for blank template 2016-01-05 04:44 EST
oVirt gerrit 51366 ovirt-engine-3.6 MERGED webadmin: spice and vnc not available for blank template 2016-01-11 10:35 EST

  None (edit)
Description Shira Maximov 2015-11-09 11:11:54 EST
Description of problem:
SPICE+VNC feature should not be available when creating a VM from Blank template on 3.5 cluster, since SPICE+VNC is 3.6 feature 

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.6.0.3-0.1.el6


How reproducible:
100%

Steps to Reproduce:
1. edit the blank template
2. go to Console tab 
3. in Graphics protocol choose VNC+SPICE
4. create 2 vms with this template -
   one with the 3.5 cluster and one with 3.6

Actual results:
The vm in 3.6 cluster will inheritance the VNC+SPICE and the vm in 3.5 should be inherit only SPICE but she also inheritance VNC+SPICE

Expected results:
The vm in 3.5 should be inherit only SPICE 

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-10 09:43:40 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 2 Sandro Bonazzola 2015-12-23 08:43:15 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA
Comment 3 Ilanit Stein 2015-12-28 07:28:34 EST
Tested on rhevm 3.6.2-2.

Followed the Steps to reproduce in the description.

Encountered a regression bug on step 3., bz 1294488. 

* Created VM on 3.6 cluster, and it inherited the console VNC_SPICE - 
This is OK.

* Created VM on 3.5 cluster, and it inherited the console VNC+SPICE - 
This is not OK, and should have been fixed.
Comment 4 Red Hat Bugzilla Rules Engine 2015-12-28 07:28:37 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Michal Skrivanek 2016-01-25 07:47:08 EST
*** Bug 1299486 has been marked as a duplicate of this bug. ***
Comment 6 Red Hat Bugzilla Rules Engine 2016-01-28 07:16:46 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 7 Red Hat Bugzilla Rules Engine 2016-01-28 07:25:06 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 8 Red Hat Bugzilla Rules Engine 2016-01-28 07:28:42 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 9 Shira Maximov 2016-02-07 06:52:45 EST
verified on :  Red Hat Enterprise Virtualization Manager Version: 3.6.3-0.1.el6 

Verification steps:
1. edit the blank template
2. go to Console tab 
3. in Graphics protocol choose VNC+SPICE
4. create 2 VMS with this template -
   one with the 3.5 cluster and one with 3.6 and one with 3.4 cluster.

the console type in 3.6 - SPICE+VNC
the console type in 3.5 + 3.4 - SPICE or VNC

Note You need to log in before you can comment on or make changes to this bug.